git clone https://git.launchpad.net/<repo>

Asked by Manoj Iyer on 2016-01-14

When I try to do:

git clone https://git.launchpad.net/<blah>

I get:
Cloning into '<blah>'...
Username for 'https://git.launchpad.net':
Password for 'https://<xxx>@git.launchpad.net':

It asks for username/passoword, if I use launchpad username and password it does not work.
remote: Authorisation required.
fatal: Authentication failed for 'https://git.launchpad.net/<blah>

1. What is the username/password I need to use?
2. What is the correct https url format ?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2016-01-14
Last query:
2016-01-14
Last reply:
2016-01-14
Best Colin Watson (cjwatson) said : #1

Your https URL format is correct, but, at present, git/https only works for public repositories where authentication isn't required. You must use SSH instead for private repositories (i.e. 'git clone git+ssh://git.launchpad.net/<blah>'.)

We'll probably fix this soon, at which point you'll generate an access token in the web UI and then use that, but the exact details aren't settled yet.

Manoj Iyer (manjo) said : #2

Thanks Colin Watson, that solved my question.