cannot import gpg key

Asked by numerodix on 2008-03-26

I'm trying to import my gpg key by following

On Step4 I'm stalled. will not accept my key. Output:


Launchpad could not import your OpenPGP key.

    * Did you enter your complete fingerprint correctly? A fingerprint is a long sequence of numbers and letters. You should use the output produced by the command:

          gpg --fingerprint

    * Have you published your key to a public key server? You can do that by by entering in a terminal:

          gpg --keyserver --send-keys

    * Has your key been automatically mirrored to the Ubuntu key server? Keys sometimes take up to an hour to be synchronized between servers. You can check if it has by querying the Ubuntu key server directly. If it hasn't, you can publish directly to our server by entering in a terminal:

          gpg --keyserver --send-keys


When I click the link it provides: my key is listed.

Steps to test:
$ gpg --fingerprint 9504FE73
pub 1024D/9504FE73 2008-03-26
      Key fingerprint = 00C9 9373 5964 2F57 4CAC E857 1DB7 5B47 9504 FE73
uid Martin Matusiak (numerodix) <email address hidden>
sub 2048g/A451DEBA 2008-03-26

$ gpg --keyserver -n --recv-keys 00c9937359642f574cace8571db75b479504fe73
gpg: requesting key 9504FE73 from hkp server
gpg: key 9504FE73: "Martin Matusiak (numerodix) <email address hidden>" not changed
gpg: Total number processed: 1
gpg: unchanged: 1

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
numerodix (numerodix) said : #1

Import worked just now.

Diogo Matsubara (matsubara) said : #2


can you try again? Launchpad uses a internal keyserver which is a mirror of
It's updated often but if you send the key to and immediately try to import it into Launchpad you might get that message. Let me know how it goes.


numerodix (numerodix) said : #3

Yeah, all good now.

Diogo Matsubara (matsubara) said : #4

Launchpad uses a internal keyserver which is a mirror of
It's updated often but if you send the key to and immediately try to import it into Launchpad you might get an error message like: "Launchpad could not import your OpenPGP key."

Trying the import a bit later usually works.
FAQ #79: “Just sent my gpg key to the keyserver but Launchpad can't import it. What should I do?”.

cac (ca-coget) said : #5

My import in Launchpad also worked fine.

Eric Lake (ericlake) said : #6

I can get the import to work but I never get the encrypted email to finish the process. I get as far as:

"A message has been sent to myemailaddress, encrypted with the key mykey. To confirm the key is yours, decrypt the message and follow the link inside. "

After 5 hours of waiting I still had no email. I changed my preferred email address and tried again but still no luck.

Stonepost (shawnmsaling) said : #7

Hello All,
   I created and registered my key with ubuntu keyserver around 5pm this evening, it is now 10:30 and still receiving the unable to inport key message. I noticed that the web services were read only for Launchpad until 11:30 UTC - which is 6:30pm EST. Has this effected / still effecting Launchpad web services?

Same thing here. Registered my key with Ubuntu Keyserver 01:00, still can't import OpenPgp Key into Launchpad at 22:20. Checked and key IS in Ubuntu Keyserver.

Marcin Cieślak (saperski) said : #9

Unfortunately, same here. I have exported my key to weeks ago and it still could not be imported
(I get the same message as the original poster).

My key is here:

This is a PGP key created with PGP 2.x in the old times.


dexterhu (dexterhu) said : #10

Unfortunately, same here:

 my key is at:

the fingerprint out there shows: 53BE 39C4 2A46 6FB7 3D33 A31D C97B BC48 DBC3 CFCB

Is this because the synchronisation between your internal server and takes hours?
But the help doc says it takes at most 30 MINUTES.

Dexter H. Hu