Error building dpkg in PPA

Asked by Giovanni Santini on 2015-06-29

I'm trying to backport dpkg from trusty to precise.
The build locally work flawlessy, but not online; actually, I tried uploading my sources at this PPA: https://launchpad.net/~itachi-san/+archive/ubuntu/freshplayerplugin
But the builds failed saying that debhelper was not avaible.
i386 build failure: https://launchpad.net/~itachi-san/+archive/ubuntu/freshplayerplugin/+build/7583815
amd64 build failure: https://launchpad.net/~itachi-san/+archive/ubuntu/freshplayerplugin/+build/7583814
Actually, I had to backport debhelper (from trusty to precise) because of cmake (in the PPA linked above)...
I think that the builder can't handle the newer version, as uploading dpkg in another PPA (https://launchpad.net/~itachi-san/+archive/ubuntu/useless) made a successful build (becasue there is no backported debhelper...?)
I solved problems marking the second PPA as a dependency of the first, but I would like to push dpkg in the first PPA.
Any ideas? Should I try to build the package again?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2015-06-29
Last query:
2015-06-29
Last reply:
2015-06-29
Best Colin Watson (cjwatson) said : #1

The problem is that your debhelper package is uninstallable until that PPA contains a new dpkg, because it Depends: dpkg-dev (>= 1.17.0), which is newer than the version in precise. You'll need to break that loop somehow. Given that you've already built a newer dpkg in another PPA, then my suggestion would be to simply copy that package into https://launchpad.net/~itachi-san/+archive/ubuntu/freshplayerplugin, which you can do from https://launchpad.net/~itachi-san/+archive/ubuntu/useless/+copy-packages.

Giovanni Santini (itachi-san) said : #2

Thanks Colin Watson, that solved my question.

Giovanni Santini (itachi-san) said : #3

I hate pre-formatted answers. :P
Anyways, I just deleted debhelper, updated the version number for both dpkg and debhelper and reuploaded (first dpkg, then debhelper)