Relocate to different remote repository

Asked by David Llewellyn-Jones on 2015-06-05

I'm working on the Knot 3D project (https://code.launchpad.net/knot) which has moved repository (also switched from SVN to Git) and so would like to change the remote repository

From svn: https://www.flypig.org.uk/svn/repos/Home/Knot/trunk/

To git as shown on this page: https://sourceforge.net/p/celticknot/code/ci/master/tree/
e.g. as in git clone git://git.code.sf.net/p/celticknot/code celticknot-code

However, when I try to delete the existing branch I get the following error:

"Oops! Sorry, something just went wrong in Launchpad. We’ve recorded what happened, and we’ll fix it as soon as possible. Apologies for the inconvenience. (Error ID: OOPS-1f5b201b25fa78dec19b5a3299a6cbd0)"

Could you please advise about how I can move to the different remote repository?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
David Llewellyn-Jones
Solved:
2015-06-05
Last query:
2015-06-05
Last reply:
2015-06-05
William Grant (wgrant) said : #1

The problem appears to be recipe that's using the branch. Deleting the branch should automatically delete the recipe too, but can you try deleting the recipe manually first?

David Llewellyn-Jones (flypig) said : #2

Beautiful! Deleting the recipe allowed me to delete the branch without problem. I've now been able to create a new branch pulled from the new location.

When I originally tried to delete the branch it suggested the recipe would be deleted automatically. I'm not sure if it helps, but changing this message (just to suggest the recipe should be deleted first) would make things clearer I guess.

Thank you! Blown away by your fast response.

William Grant (wgrant) said : #3

It's meant to automatically delete it, but it clearly didn't work in this case. I'll investigate why, but glad you got it sorted out.