add new builds to current LibrePlan source

Asked by Jeroen Baten on 2014-06-04

How can I add builds for other ubuntu versions to the current LibrePlan PPA (that I try to manage).

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2014-06-04
Last reply:
2014-06-17
William Grant (wgrant) said : #1

You'll need to go through https://help.launchpad.net/Packaging/PPA and http://packaging.ubuntu.com/html/ to learn how to create and upload Ubuntu packages to Launchpad.

Jeroen Baten (jbaten) said : #2

I understand that. My question is: the current available packages in the LibrePlan PPA are already there. They are the same for all other ubuntu versions. Is there a way to re-use the current files to add support for (as an example) Trusty to the ppa?

William Grant (wgrant) said : #3

https://launchpad.net/~libreplan/+archive/ppa/+packages shows separate versions for lucid, precise and quantal. In some circumstances you can use the "Copy packages" link, but you need to manually verify that the binaries work on the new Ubuntu version. In the general case, you need to change the version in debian/changelog and upload the new package.

LibrePlan (libreplan) said : #4

Hi,

I tried to copy the packages since I have verified manually that they also work on newer Ubuntu versions
but I get the following error.

Copying failed of libreplan (1.4.0-1.lucid) Remove notification Remove notification
Copied from: LibrePlan. Target series: Saucy
libreplan 1.4.0-1.lucid in lucid (same version already has published binaries in the destination archive)
Copying failed of libreplan (1.4.0-1.lucid) Remove notification Remove notification
Copied from: LibrePlan. Target series: Trusty
libreplan 1.4.0-1.lucid in lucid (same version already has published binaries in the destination archive)

What am I doing wrong?

William Grant (wgrant) said : #5

You need to select the "Copy existing binaries" option. Otherwise it would attempt to build fresh binaries with the same version, which wouldn't work very well.

Rolando Garza (rolandog) said : #6

Is there a plan to add Wily to the list of supported Ubuntu versions?

Colin Watson (cjwatson) said : #7

Rolando, you should ask the LibrePlan PPA maintainers separately.about that (i.e. not in a question filed against Launchpad itself).

Can you help with this problem?

Provide an answer of your own, or ask Jeroen Baten for more information if necessary.

To post a message you must log in.