PPA build completes, but uploading takes forever

Asked by Andreas Roth on 2014-05-20

Hi,

i wanted to build the latest version of GDB 7.7.1 for saucy and trusty. I've taken the latest packages from utopic and changed the changelog for saucy and trusty accordingly and uploaded the source package to my PPA. Both packages are building just fine until they reach the line 'dpkg-buildpackage: binary only upload (no source included)'.
Here are the builds:
trusty: https://launchpad.net/~aroth/+archive/testing/+build/6024643
saucy: https://launchpad.net/~aroth/+archive/testing/+build/6024645

What's wrong with this package? Why is the build stopped/paused at this point?

It seems that the building is waiting for something, but i do know for what.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Colin Watson
Solved:
2014-05-20
Last query:
2014-05-20
Last reply:
2014-05-20
Colin Watson (cjwatson) said : #1

This happens when your build has left some stale processes around, typically things like server processes run in test suite harnesses. Here's the relevant bit of the process tree on amd64:

buildd 6384 0.0 0.0 10548 540 ? Sl 05:21 0:00 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-nonstop
buildd 6405 0.0 0.0 4144 400 ? R 05:21 0:26 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-ns-stale-regcache
buildd 6434 0.3 0.0 16704 556 ? Rl 05:21 1:49 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-nsintrall
buildd 6505 0.0 0.0 6336 368 ? R 13:34 472:20 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-nsthrexec

And on i386:

buildd 5157 0.0 0.0 10552 556 ? Sl 05:32 0:00 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-nonstop
buildd 5175 0.0 0.0 4152 412 ? S 05:32 0:25 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-ns-stale-regcache
buildd 5200 0.3 0.0 16708 576 ? Sl 05:32 1:49 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-nsintrall
buildd 5263 0.0 0.0 6332 216 ? R 13:33 459:31 /build/buildd/gdb-7.7.1/build/objdir/gdb/testsuite/gdb.mi/mi-nsthrexec

It isn't going to succeed by itself, so your best bet is to cancel the build, fix this locally, and try again.

Andreas Roth (aroth) said : #2

Thanks for you answer.

Just one follow up question:
Since i just uploaded only a slighly modified version of the original Ubuntu gdb package (only changed the dist-codename in the changelog) i'm surprise to find that my package does not build but the original package obliviously builds.
What's the difference between the original Ubuntu build set up and the PPA build set up? Aren't the original ubuntu packages built with the same set up?

Best Colin Watson (cjwatson) said : #3

They are very similar, although virtualised PPAs build in a Xen guest which currently uses the Hardy kernel, and that can cause some issues. You could try directly copying the package from Ubuntu (using copy-package from lp:ubuntu-archive-tools) rather than reuploading a changelog-modified version, just in case the packaging does odd things depending on its changelog target.

Failing that, you'll probably need to ask somebody who knows specifically about gdb.

Andreas Roth (aroth) said : #4

Thanks Colin Watson, that solved my question.