Removed submodules but import still fails

Asked by Thomas Karl Pietrowski on 2014-01-11

As you can see here all submodules have been removed from https://github.com/LubosD/darling.git :
https://github.com/LubosD/darling/commit/bfd22412b9768fd97f4df1771a8c87a1da199dd7

https://code.launchpad.net/~thopiekar/darling-emu/darling

Why does that happen? Do you know a way how to fix that, even on the git branch?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
William Grant
Solved:
2014-01-14
Last query:
2014-01-14
Last reply:
2014-01-13
William Grant (wgrant) said : #1

Due to the nature of git, bzr has to be able to reproduce each revision in a branch's history. This means that submodules have to not even exist in the branch's history -- you'd need to rewrite the revisions since the submodule was first introduced.

Well, rewriting the history is not an option. So I just have to manually import the code?

Best William Grant (wgrant) said : #3

That's correct. Submodules can't be imported, so the history cannot be represented, and since git can send deltas from any revision in history we need to have the entire history available.

Ok, I'll do manuall imports then..
Not really solved the problem, but helped to understand.