The import has been suspended because it failed 5 or more times in succession.

Asked by Karl Ellis on 2013-12-17

Hi,
 today I try requesting an import for lp:webcamstudio source code daily builds, but it fails with:

2013-12-17 19:26:30 INFO Starting job.
2013-12-17 19:26:30 INFO Getting exising bzr branch from central store.
ssh: Could not resolve hostname escudero: Name or service not known

Traceback (most recent call last):
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/scripts/code-import-worker.py", line 95, in <module>
    sys.exit(script.main())
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/scripts/code-import-worker.py", line 90, in main
    return import_worker.run()
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/lib/lp/codehosting/codeimport/worker.py", line 586, in run
    return self._doImport()
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/lib/lp/codehosting/codeimport/worker.py", line 720, in _doImport
    bazaar_branch = self.getBazaarBranch()
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/lib/lp/codehosting/codeimport/worker.py", line 544, in getBazaarBranch
    stacked_on_url=self.source_details.stacked_on_url)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/lib/lp/codehosting/codeimport/worker.py", line 168, in pull
    remote_bzr_dir = BzrDir.open(remote_url)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/controldir.py", line 689, in open
    _unsupported=_unsupported)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/controldir.py", line 718, in open_from_transport
    find_format, transport, redirected)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/__init__.py", line 1719, in do_catching_redirections
    return action(transport)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/controldir.py", line 706, in find_format
    probers=probers)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/controldir.py", line 1151, in find_format
    return prober.probe_transport(transport)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/bzrdir.py", line 1237, in probe_transport
    format_string = transport.get_bytes(".bzr/branch-format")
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/sftp.py", line 422, in get_bytes
    f = self.get(relpath)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/sftp.py", line 412, in get
    f = self._get_sftp().file(path, mode='rb')
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/sftp.py", line 389, in _get_sftp
    connection, credentials = self._create_connection()
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/sftp.py", line 376, in _create_connection
    self._parsed_url.host, self._parsed_url.port)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/ssh.py", line 391, in connect_sftp
    self._raise_connection_error(host, port=port, orig_error=e)
  File "/srv/importd.launchpad.net/production/launchpad-rev-16869/eggs/bzr-2.6.0-py2.6-linux-i686.egg/bzrlib/transport/ssh.py", line 259, in _raise_connection_error
    orig_error=orig_error)
bzrlib.errors.SocketConnectionError: Unable to connect to SSH host escudero; EOF during negotiation
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

I don't know if it is my fault, i didn't configure the ppa and i can't contact the person who made it.
I usually commit source changes on WebcamStudio google code only.
I try requesting others imports but all fails with the same log. Now i see the message "The import has been suspended because it failed 5 or more times in succession. ".
Thanks.
karl.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
William Grant
Solved:
2013-12-18
Last query:
2013-12-18
Last reply:
2013-12-18
Best William Grant (wgrant) said : #1

There was an issue with our internal network. That's fixed now, and the import is succeeding again.

Karl Ellis (soylent-tv) said : #2

Thanks William Grant, that solved my question.

Karl Ellis (soylent-tv) said : #3

Thank You very much :)
karl.