Packages failing to build in trusty

Asked by Jasem Mutlaq

All my packages build fine on everyting from precise to saucy, but fail in trusty with the following error:

 dpkg-source -i -I --before-build recipe-{debversion}+r{revno}-{revno:packaging}
 fakeroot debian/rules clean
dh clean --parallel
   dh_testdir -O--parallel
   dh_auto_clean -O--parallel
   dh_clean -O--parallel
 dpkg-source -i -I -b recipe-{debversion}+r{revno}-{revno:packaging}
dpkg-source: error: can't build with source format '3.0 (native)': native package version may not have a revision
dpkg-buildpackage: error: dpkg-source -i -I -b recipe-{debversion}+r{revno}-{revno:packaging} gave error exit status 255

I don't understand the error above, in debian/changelog, I have this

libindi (0.9.7) precise; urgency=low

  * New upstream release.

So I'm not using any hyphens...etc. What is the problem?

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Jasem Mutlaq
Last query:
Last reply:
Revision history for this message
Fabien Cortina (fabien.cortina) said :
Revision history for this message
Jasem Mutlaq (mutlaqja) said :

I already looked at that before I opened this ticket, and I still don't know what exactly I have to do in order to resolve this. Can you be more specific of what exactly needs to be done?!

Revision history for this message
Jasem Mutlaq (mutlaqja) said :

Turns out the solution is to remove the hypthen from the DEB string (and not the actual package name in Changelog). I replaced the hyphen in the recepie deb string with a dot and it worked.