error copying packages

Asked by Sol Jerome on 2013-06-11

I receive this error when trying to copy a package to the Bcfg2 lucid testing repository (https://launchpad.net/~bcfg2/+archive/lucidtesting):

Launchpad encountered an error during the following operation: copying a package. python-django-south 0.7.5-1~lucid2 in lucid (same version already has published binaries in the destination archive)

This repository has no published binaries for that package, however. How can I successfully copy the package to this repository?

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2013-06-11
Last reply:
2013-06-13
Sol Jerome (solj) said : #2

Only the desktop is EOL. Lucid server isn't EOL until 2015 https://wiki.ubuntu.com/Releases#Stable.

William Grant (wgrant) said : #3

Conflicting binaries must never have existed in the history of the archive. If you look at https://launchpad.net/~bcfg2/+archive/lucidtesting/+packages?field.name_filter=python-django-south&field.status_filter=&field.series_filter= you'll see that the package has existed in that PPA before, but was later deleted.

If the old binaries are fine, you can copy the deleted package back into the same PPA to undelete it. If you need new binaries, you'll need to upload a new version with a newer version number.

Can you help with this problem?

Provide an answer of your own, or ask Sol Jerome for more information if necessary.

To post a message you must log in.