Importing translation gives "tuple index out of range" error

Asked by fisharebest on 2013-05-18

The import queue for my project - https://translations.launchpad.net/webtrees/trunk/+imports - shows a failed import for the file http://launchpadlibrarian.net/140096240/el.po

Yes it is normal for uploaded .PO files to have errors, but this error - "tuple index out of range" - does not appear to be one of the usual GETTEXT errors. It appears to be a python error, which suggests an error in launchpad, rather than my translation file.

Should I raise a bug report for this?
Is there anything I can do to help investigate or diagnose the problem?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2013-06-01
Last reply:
2013-06-03
Jeroen T. Vermeulen (jtv) said : #1

This sounds like a problem with plurals somewhere, but I see nothing unexpected in the plurals.

There should be a Last-Translator in the header though. Have you tried setting the translator's name and email address there?

fisharebest (fisharebest) said : #2

I've just tried adding my email address to the Last-Translator field and re-submitting the file.
I get the same "tuple out of range" error.

I've also reviewed the plural translations.

I can compile the file happily using msgfmt

fisharebest (fisharebest) said : #3

I have now tried uploading a new .POT file.

I get the same error message.

This .POT file is generated by the same script that has been used for many years. So, I'm pretty sure there is nothing wrong with the file.

Should I raise a bug report?

Laura Czajkowski (czajkowski) said : #4

Issue is being tracked via bug