Build-depends-indep requirement fails amd64, passes i386

Asked by Elliot Saba on 2013-04-04

I have a package which built on i386, but failed on amd64, because of a Build-Depends-Indep requirement that was installed on i386, but not on amd64. Here is the failure log: https://launchpadlibrarian.net/136172973/buildlog_ubuntu-precise-amd64.lapack_3.4.2%2Bdfsg-juliadeps1_FAILEDTOBUILD.txt.gz

If you search for doxygen, you can see that it is required in the Build-depends-Indep, but then you get a "command not found" at the bottom when it is actually tried to be used. Can anyone explain to me why this happens? This package is also a backport from raring, so I'm pretty sure it should work just fine. (the fact that it worked on i386 is encouraging, at least)

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
William Grant
Solved:
2013-04-04
Last query:
2013-04-04
Last reply:
2013-04-04
Best William Grant (wgrant) said : #1

Build-Depends-Indep is only installed on i386, because architecture-independent packages are only built on that architecture. But dpkg before 0.16.2 always calls the 'build' debian/rules target, not 'build-arch' or 'build-indep', so some backports to precise won't work. The easiest workaround is to just merge Build-Depends-Indep into Build-Depends.

Elliot Saba (staticfloat) said : #2

Thanks William Grant, that solved my question.