amd64 build errors out by using dependency built for i386

Asked by Braden Pellett on 2013-03-14

Several packages in my PPA rely upon one of the other packages in that PPA. Many builds ended up failing because the i386 package of the depended-upon package was finished first, and then when the amd64 builds of the dependent packages started, they ended up trying to compile against the built i386 package and failing, instead of waiting for the amd64 version to be built.

Is there some way to prevent this scenerio?

The PPA in question is KeckCAVES

Thank you.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Adam Conrad
Solved:
2013-03-15
Last query:
2013-03-15
Last reply:
2013-03-15
Best Adam Conrad (adconrad) said : #2

This was a misconfiguration in the oneiric/amd64 buildd chroot that I hadn't noticed (precise and later are fine). I've fixed it and retried your build, and all is well now. Thanks for noticing and raising the issue.

Braden Pellett (dabrado) said : #3

Thank you for fixing it!

Braden Pellett (dabrado) said : #4

Thanks Adam Conrad, that solved my question.