A way to build an ubuntu-based package with custom patches with recipe

Asked by Andrei Dziahel


I want to automate applying custom homemade patch to ubuntu package (namely xkeyboard-config). I thought it can be achieved with packaging recipe like following:

> # bzr-builder format 0.3 deb-version {debupstream}-0~{revno:patch}
> ubuntu:quantal/xkeyboard-config
> merge patch lp:~develop7/xkeyboard-config/rube-layout

This approach failed: build bot didn't know how to handle "ubuntu:" bzr scheme

Next try with
> # bzr-builder format 0.3 deb-version {debupstream}-0~{revno:patch}
> lp:ubuntu/quantal/xkeyboard-config
> merge patch lp:~develop7/xkeyboard-config/rube-layout
failed too: https://launchpadlibrarian.net/131430922/buildlog.txt.gz

Even branch stacked on branch in ubuntu was failed to check out by bot as well — https://launchpadlibrarian.net/131436617/buildlog.txt.gz

Not mentioning that lp:ubuntu/quantal/xkeyboard-config contains version older than one in repositories.

So, are there ways how to make this possible without patching package locally and uploading it to PPA?

Thank you in advance.

P.S. Recipe that doesn't work resides in https://code.launchpad.net/~develop7/+recipe/xkeyboard-config-rube-daily

Question information

English Edit question
Launchpad itself Edit question
Steve Kowalik Edit question
Solved by:
Steve Kowalik
Last query:
Last reply:
Revision history for this message
Best Steve Kowalik (stevenk) said :

I have created a recipe with the same conditions: https://code.launchpad.net/~stevenk/+recipe/xkeyboard-config-daily

The first build was just against lp:ubuntu/quantal/xkeyboard-config which was successful.

Before the second build, I added in the merge directive, and requested another build, which also worked. If you ignore the could not be uploaded error, since it was attempting to upload the same version: https://code.launchpad.net/~stevenk/+archive/ppa/+recipebuild/408121 will show the build was successful.

I suspect your branch was stacked on an invalid branch, which caused it to not merge correctly.

Revision history for this message
Steve Kowalik (stevenk) said :

Oops. Needs a reply from the requester.

Revision history for this message
Andrei Dziahel (develop7) said :

Thanks Steve Kowalik, that solved my question.