Launchpad builds are taking days.

Asked by Michael W Tremblay on 2013-02-19

Both the i386 and x64 builds on my PPA are taking a very long time. The last one auto-cancelled after two days.

The build logs on the servers state that the package builds successfully within about seven minutes, however; the Launchpad site says that they are still building.

Have I done something wrong with configuring my package?

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
William Grant Edit question
Solved by:
Colin Watson
Solved:
2013-09-27
Last query:
2013-09-27
Last reply:
2013-09-09
William Grant (wgrant) said : #1

That usually indicates that your package has left a daemon around, or some other orphaned process that remains running after the build completes. Have you confirmed locally that nothing started by the build remains running?

I have not verified this, but you have given me something to check for once I am home from work. If it is relevant this is the software that I am trying to build mednafen.sourceforge.net.

Thank you for your quick response :)

I have just built the package at home using pbuilder and nothing seems to be still running, or perhaps I am not looking in the right place. Is there anything that I could provide that would help towards resolving the issue? My config.log perhaps?

Bump.

Any ideas?

Best Colin Watson (cjwatson) said : #5

I believe your problem is that you have constructed this upload manually in a somewhat incorrect way. Your package is versioned 0.9.28-wip-0ubuntu2, but if I unpack the source package there's only one entry in debian/changelog and that's for version 0.9.28-wip-0ubuntu1. This causes the builder to get very confused (the clue was "Can't find medhafen_0.9.28-wip-0ubuntu1_i386.changes -- can't dump infos" before the cancel) and it gets stuck.

You should upload a new version of your package where debian/changelog corresponds to the version of the package (the "dch" tool is handy). It looks like you edited the .dsc and .changes manually, and if my guess there is right then you should refrain from doing this next time.

Colin Watson (cjwatson) said : #6

Sorry, that was "Can't find medhafen_0.9.28-wip-0ubuntu2_i386.changes -- can't dump infos" (I forgot to copy and paste it before the cancel took place so I was retyping it from memory).

Colin Watson (cjwatson) said : #7

https://dogfood.launchpad.net/~cjwatson/+archive/devirt-ppa/+build/4952726 (until the database on that Launchpad instance is next reset) shows the fixed behaviour. I'm going to tweak it a little more so that the actual failure shows up very slightly more clearly in the build log.

Colin,

Thank you for your help. Hopefully I'll have some time this weekend to dive back into this, it's been a while.

Mike

Thanks Colin Watson, that solved my question.