Failing import from Debian's Alioth Bzr

Asked by Andrew Starr-Bochicchio on 2012-11-23

The branch lp:~andrewsomething/imagination/debian is an import from http://bzr.debian.org/collab-maint/imagination/unstable/

It has been marked as failing. The error is:

2012-11-23 19:09:14 INFO Starting job.
2012-11-23 19:09:14 INFO Getting exising bzr branch from central store.
2012-11-23 19:09:14 INFO [chan bzr SocketAsChannelAdapter] Opened sftp connection (server version 3)
2012-11-23 19:09:14 INFO 35 bytes transferred
2012-11-23 19:09:58 INFO Unable to open remote branch: Connection error: while sending GET /bzr/collab-maint/imagination/unstable/.bzr/branch-format: [Errno 110] Connection timed out

I'm not sure why it's timing out. I can connect to it:

$ bzr info http://bzr.debian.org/collab-maint/imagination/unstable/
http://bzr.debian.org/collab-maint/imagination/unstable/ is permanently redirected to http+urllib://anonscm.debian.org/bzr/collab-maint/imagination/unstable/
Standalone branch (format: 2a)
Location:
  branch root: http+urllib://anonscm.debian.org/bzr/collab-maint/imagination/unstable/

Maybe it is the re-direct?

Unless someone knows better, could someone please set the import url point directly to the anonscm.debian.org one?

Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
William Grant
Solved:
2014-01-15
Last query:
2014-01-15
Last reply:
2013-05-23
Curtis Hovey (sinzui) said : #1

redirects are often a problem. I changed the URL to
    http://anonscm.debian.org/bzr/collab-maint/imagination/unstable/

We are waiting for the next import to attempt.

Best William Grant (wgrant) said : #2

Alioth had throttled anonscm HTTP access from Canonical's networks. That's fixed now, and the import works.

Thanks William Grant, that solved my question.