Can make a debian/watch file with a project host in Launchpad ?

Asked by Julien Lavergne on 2008-01-01

I try to make a debian/watch file for 2 projects in Launchpad to track upstream release, but all my diffrents files fail to scan for new release.
Is it working for Launchpad Project ? Do you have an example of a watch file working ?

Thanks in advance.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Julien Lavergne
Last query:
Last reply:

This question was reopened

James Henstridge (jamesh) said : #1

I haven't tried it yet, but can you do something like this?

  version=3$PROJECT/+download foo-(.*).tar.gz

Chris Jones (cmsj) said : #2

James: I'm trying to do the same thing and your scheme didn't work for me with this:

version=3 terminator_(.+)\.tar\.gz

I've been somewhat inconsistent with my tarball names in the past, but there is one that should match that (terminator_0.6.tar.gz)

Julien Lavergne (gilir) said : #3

Thanks for the reply

The classic format doesn't work (that's because I asked :))
I think I try all format, but nothing work.
And the link for my download is more complicated :

James Henstridge (jamesh) said : #4

I just tried putting together a watch file for bzr-pqm, and the following worked okay:


I then get the following output when running it:

    $ uscan --report-status .
    Processing watchfile line for package bzr-pqm...
    Newest version on remote site is 0.92.0, local version is 0.92.0
     => Package is up to date

Julien Lavergne (gilir) said : #5

Yes! It's work now :)
Thanks a lot :)

Julien Lavergne (gilir) said : #6

Thanks James Henstridge, that solved my question.

Julien Lavergne (gilir) said : #7

After the 1.2.3 release, all watch files are broken (links changed) ...
Anyone found a solution ? All my attempts to rewrite the file was a problem ...

Christian Reis (kiko) said : #8

What links changed?

Christian Reis (kiko) said : #10

Well, I don't actually think the URLs to downloads changed, and even if it did, your regular expression would still work (because ".*" would cover "+download"). There's something else wrong. What does --debug tell you?

Christian Reis (kiko) said : #11

Oh! There was one thing that changed -- the actual download URLs are now HTTP, not HTTPS. So try this:

New watch file (don't work)*/+download/screenlets-(.+).tar.gz

Julien Lavergne (gilir) said : #12

It did not solve my problem ...

...but, switch to http for the second link seems to solve the problem :*/screenlets-(.+).tar.gz

Thanks for point this to me :)

Christian Reis (kiko) said : #13

The reason +download doesn't work, btw, is probably because you haven't escaped the +. If you do \+ I bet it works.

Savvas Radevic (medigeek) said : #14

No +download is correct, the link (before the space) tells uscan the website to look for the expression (after the space)

There's a bug if anyone is interested: