upstream connection isn't correct

Asked by Todd Kennedy on 2012-02-17

The upstream connection point for this package is pointing to a Python ETL tool called OpenConnect. Obviosuly this is the wrong package and it should be pointing to openconnect VPN package.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
John A Meinel
Solved:
2012-08-10
Last query:
2012-08-10
Last reply:
2012-08-09

This question was originally filed as bug #934449.

Making this into a question so that launchpad operators can fix the issue.

I'm suggesting renaming the current openconnect project to openconnect-etl; or removing it altogether since there doesn't seem to be anything used by it.

The proper URL for the openconnect project is http://www.infradead.org/openconnect/; linked to the package 'openconnect' in Debian, Ubuntu and other distros.

John A Meinel (jameinel) said : #3

I can see your point, and I agree that https://launchpad.net/ubuntu/+source/openconnect should *not* be connected to https://launchpad.net/openconnect.

I agree that the existing lp.net/openconnect seems not very fleshed out. However, I also don't see a project that is pointing at infradead either.

I can easily just delete the upstream link, though, and have done so.

Best John A Meinel (jameinel) said : #4

NM, after breaking the connection, Launchpad was actually helpful about suggesting a link to network-manager-openconnect, which does seem like a decent fit.

So aside from naming, does that fix your problem?

Mike Miller (mtmiller) said : #5

I think this is a little misleading, as openconnect is distinct from and quite useful without network-manager.

It would be more useful if https://launchpad.net/openconnect were linked to the proper upstream description and repository at infradead.org/openconnect. This would be the clearest representation, that is how the software is known in all major distributions. I don't think I'm out of line saying that the project at lp/openconnect is just taking up useful namespace.

Todd Kennedy (toddkenn) said : #6

Thanks John A Meinel, that solved my question.