OpenID Launchpad Mismatch

Asked by John Tran on 2012-05-15

The OpenID my Launchpad account claims to have is
https://login.launchpad.net/+id/zQddP6p but Launchpad is sending Gerrit
https://login.launchpad.net/+id/686YpDr

Please make it so that only one OpenID is associated - it should be the first one (zQddP6p).

Thanks in advance!

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
[LEGACY] Canonical WebOps Edit question
Solved by:
John Tran
Solved:
2012-05-16
Last query:
2012-05-16
Last reply:
2012-05-16
Whiteboard:
webops to delete both openididentifiers from both Launchpad accounts, Users are to then to log out and in again.
Haw Loeung (hloeung) said : #1

Hi John,

There were two OpenIDs associated with your account which I believe is what's causing the wrong one to be sent to Gerrit. Both OpenIDs have been removed so on next login, you'll only have one associated and it should do the right thing.

Regards,

Haw

John Tran (jtran) said : #2

No luck. I logged out of both review.openstack.org and launchpad.net. Logged into launchpad, it asked me to update my password which I did. I then proceeded to log back in to review.openstack.org. I then attempted a 'git review' from my nova git repo and it still says I do not have a Contributor License Agreement.

William Grant (wgrant) said : #3

You may need to wait for review.openstack.org to rerun its cronjob which pulls the data from Launchpad.

John Tran (jtran) said : #4

I just tried again right now the same above steps , it asked me to change my password on launchpad, I re-logged into both launchpad and review.openstack.org. I then tried to submit a 'git review' and received the following still:

fatal: A Contributor Agreement must be completed before uploading:

  http://wiki.openstack.org/HowToContribute

fatal: The remote end hung up unexpectedly

John Tran (jtran) said : #5

Nevermind, please close this out. I hadn't updated my git config to set the username to the first account.