Fritzing package does not build in Launchpad

Asked by Enrique Hernández Bello on 2012-04-19


my recipe for Fritzing project fails to build at any Ubuntu releases since some time ago. However I never had any errors building in my machines.

I recive a rarely error of qmake but I don't use it directly. I import from cdbs in rules file.

Can somebody review the buildlog and tellme why it is failing?

Thank you.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
William Grant
Last query:
Last reply:
Laura Czajkowski (czajkowski) said : #1

hi please have a look at which should help you with the build in a clean environment like launchpad.

Wrong answer...

I already use pbuilder with cowdancer for my tests. I emphasize that I can build my package correctly for all specified Ubuntu releases.

I guess that It must be a problem of Launchpad build system.

William Grant (wgrant) said : #3

It's not a problem with the Launchpad build system; we build thousands of packages which use qmake fine. Your package (perhaps through is invoking qmake incorrectly:

mkdir -p "."
cd . && qmake 'QMAKE_CC = cc' 'QMAKE_CXX = g++' 'QMAKE_CFLAGS_RELEASE = -g -O2 -g -O2' 'QMAKE_CXXFLAGS_RELEASE = -g -O2 -g -O2'
Usage: qmake [mode] [options] [files]

QMake has two modes, one mode for generating project files based on

I have no problem neither running that qmake command in my machine nor building fritzing under pbuilder environment.

My package does not include upstream code and I guess that launchpad's recipes does not download the tarball using uscan before build.

How can I change this behaviour without upload upstream code?

Best William Grant (wgrant) said : #5

Recipes grab the code from a bzr branch. They can't run uscan, as there's no Internet access during builds. See for recipe documentation.

If the code can't be imported into a bzr branch, you can't use a recipe and you'll have to upload a source package yourself. See

Thanks William Grant, that solved my question.