import error for git submodules when none are present

Asked by Scott Howard on 2012-01-31

I'm aware that bzr importer can't import git repos with submodules and it's a work in progress bug, however, I'm receiving that error from a repo that doesn't have submodules.

I've been importing librecad at:
https://code.launchpad.net/~librecad-dev/librecad-dev/librecad

for about a year.

A month ago it started to fail with:
The repository you are fetching from contains submodules. To continue, upgrade your Bazaar repository to a format that supports nested trees, such as 'development-subtree'.

However, we didn't have any submodules. I deleted the bzr branch and checked the git repo: no .gitmodules, no mention of modules in .git/config

So I restarted the import, and it is failing again.

What do I need to do to my upstream git repo to avoid that?
Thanks
~Scott

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Bentley
Solved:
2012-02-01
Last query:
2012-02-01
Last reply:
2012-02-01
Best Aaron Bentley (abentley) said : #1

We are not aware of any cases where we detected submodules, but none were present. Since we import the full history, submodules are not permitted in any revision that has ever been merged, into your head branch.

To rectify the situation, you would need to rewrite your git repository so that it contained no submodules. This would probably involved rebase or mucking around with fastimport streams.

Scott Howard (showard314) said : #2

Thanks Aaron Bentley, that solved my question.