help to debug buildlog: pandas

Asked by Timmie on 2012-01-23

Please help me to debug the reason, why this fails:
https://launchpadlibrarian.net/90798524/buildlog.txt.gz

It is all based on debaina files for precise.

The relvant parts:

dpkg-buildpackage: warning: (Use -d flag to override.)
dpkg-buildpackage: warning: This is currently a non-fatal warning with -S, but
dpkg-buildpackage: warning: will probably become fatal in the future.
 fakeroot debian/rules clean
make: pyversions: Command not found
make: pyversions: Command not found
: # Explicit build system to avoid use of all-in-1 Makefile
dh clean --buildsystem=python_distutils
make: dh: Command not found
make: *** [clean] Error 127
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
RUN: /usr/share/launchpad-buildd/slavebin/scan-for-processes ['/usr/share/launchpad-buildd/slavebin/scan-for-processes', '6a4b9760b0942e78b1c7e496e3f9099f35703a85']
Scanning for processes to kill in build /home/buildd/build-6a4b9760b0942e78b1c7e496e3f9099f35703a85/chroot-autobuild...
RUN: /usr/share/launchpad-buildd/slavebin/umount-chroot ['umount-chroot', '6a4b9760b0942e78b1c7e496e3f9099f35703a85']
Unmounting chroot for build 6a4b9760b0942e78b1c7e496e3f9099f35703a85...

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Bentley
Solved:
2012-06-03
Last query:
2012-06-03
Last reply:
2012-01-25
Timmie (timmie) said : #1

The debian/rule says:

PYVERS = $(shell pyversions -vs)
PYVER = $(shell pyversions -vd)

# Mega rule
%:
 : # Explicit build system to avoid use of all-in-1 Makefile
 dh $@ --buildsystem=python_distutils

override_dh_clean:
 rm -rf build doc/_build *-stamp # pandas.egg-info pandas/datasets/__config__.py
 dh_clean
 : # prune auto-generated version.py -- will be generated during build again
 rm -f pandas/version.py

Timmie (timmie) said : #2

searching the net, it appears that debhelper is required.

In control, this is set:

Build-Depends: debhelper (>= 7.0.50),
               python-all-dev (>= 2.5), python-support (>= 0.6),
               python-setuptools, cython (>= 0.12~),
               python-numpy, python-dateutil,
               python-scipy,
               python-scikits.statsmodels,
               python-tz,
               python-tables, python-xlrd,
               python-sphinx (>= 1.0~),
               python-nose,
               python-matplotlib,

Aaron Bentley (abentley) said : #3

Are you still having trouble?

Timmie (timmie) said : #4

Yes, happened again:
https://launchpadlibrarian.net/90884245/buildlog.txt.gz

only on the Oneric build, BTW.

Best Aaron Bentley (abentley) said : #5

The build dependencies appear to be unresolvable: it says "Unable to resolve dependencies! Giving up..."

Timmie (timmie) said : #6

Thanks Aaron Bentley, that solved my question.