Unable to connect to SSH host bazaar from Windows

Asked by Vy Nguyen on 2011-10-11

I'm trying to run command "bzr branch lp: ...." to make a local copy of a branch, and I keep getting this error
"bzr: ERROR: Unable to connect to SSH host bazaar.launchpad.net; Unable to connect to bazaar.launchpad.net: [Errno 10060] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond"

Any idea what might have triggered this?

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
Martin Pool Edit question
Solved by:
Vy Nguyen
Solved:
2011-10-24
Last query:
2011-10-24
Last reply:
2011-10-18
Raphaël Badin (rvb) said : #1

Are you behind a proxy that might prevent ssh connections to bazaar.launchpad.net?
Also, could you tell us what version of bzr you're running? (run 'bzr version')

Vy Nguyen (oontvoo) said : #2

I dont think I'm behind a proxy, but suppose I was, then how would I fix this?
I believe I was using the latest version of bzr.

Raphaël Badin (rvb) said : #3

If you're behind a proxy you have to make bzr use that proxy:
set http_proxy=http://webcache.mycompany.com:3128/
(see http://doc.bazaar.canonical.com/bzr.dev/en/user-guide/configuring_bazaar.html for a more detailed answer)

What happens if you do:

telnet bazaar.launchpad.net 22

from a command prompt? If it hangs, you are firewalled and you cannot use SSH access.

Vy Nguyen (oontvoo) said : #5

@Julian Edwards: I tried typing "telnet bazaar....." to my cmd, and got this "telnet is not recognized as an internal or external command"

Vy Nguyen (oontvoo) said : #6

PS: Now I'm almost certain that I'm not behind a proxy because I'm connecting from a home network.

Still, how do I resolve the "timed out" issue when trying to branch from launchpad?

Martin Pool (mbp) said : #7

How about if you try

  bzr info bzr+ssh://<email address hidden>/+branch/launchpad

Vy Nguyen (oontvoo) said : #8

I got the same error I did when I tried to branch a project.

Vy Nguyen (oontvoo) said : #9

That is, "Unable to connect to SSH host ....[Errorno10060] ..."

Vy Nguyen (oontvoo) said : #10

Well?

Martin Pool (mbp) said : #11

Hi, oontvoo,

Error 10060 is "connection timed out". Other people can reach Launchpad so the problem is very likely either on your PC or your network. It could be any of the following:

 * your PC has a firewall or other security software that's blocking outgoing connections
 * your PC has some kind of installation or registry problem that's blocking routes to Launchpad
 * your government or ISP is blocking this connection (perhaps because it's encrypted)
 * you do actually need a proxy configuration
 * there's a configuration problem with your isp

You could try running 'tracert bazaar.launchpad.net'

You can also try

 bzr branch bzr branch http://bazaar.launchpad.net/~bzr-pqm/bzr/bzr.dev

which will give you a readonly connection over http and may work if there is a filtering problem.

Vy Nguyen (oontvoo) said : #12

Thanks for the info, Martin!

I checked, and it wasn't because of my PC. I was able to connect to launchpad from my laptop at work. SO it's pretty much due to my home network connection.

So what exactly do I need to change to be able to connect to launchpad from home?

Vy Nguyen (oontvoo) said : #13

Nevermind, I figured it out. :)

Martin Pool (mbp) said : #14

Great.