Please hide my email address

Asked by Rolf Broberg

I registered today and agreed to let you know my email address, because I wanted you to have an opportunity to contact me. But for me it was not the same as exposing it publicly on the web for every email address robot. I could not remove my email address, but I noticed that some other users have "No public address provided" in their public profile. Please hide my email address in the same way.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Rolf Broberg
Solved:
Last query:
Last reply:
Revision history for this message
Max Bowsher (maxb) said :
#1

To change your own settings, visit https://launchpad.net/people/+me/+edit and see "Hide my email addresses from other Launchpad users" near the bottom of the page.

Revision history for this message
Rolf Broberg (rolf-9) said :
#2

Thanks! By clicking on your link, I can see the option "Hide my email addresses from other Launchpad users", and it was checked. When I am not logged-in and click on my name in a discussion thread, I see "Email: Log in for email information", but after logging in, my email address is exposed. I now understand that I have to create a second user account if I want to verify that another logged-in user can't see the email address of my primary user. There is nothing in my "User information" page that tells me that my email address is protected. That option is not available from there as far as I can see.

Revision history for this message
Max Bowsher (maxb) said :
#3

There is a padlock next to your email address on https://launchpad.net/~rolf-9 - if you hover the mouse over it, you should see a "This email address is not disclosed to others." tooltip.

Revision history for this message
Rolf Broberg (rolf-9) said :
#4

You are right. Sorry, I didn't notice. Thanks Max for good and fast response!

Revision history for this message
Rolf Broberg (rolf-9) said :
#5

If there was a 'This Solved My Problem' button at #3, I would have pressed it. Unfortunately only #1 has such a button.