Code import taking too long

Asked by Philipp Kern on 2011-08-19

The import for seems to take a very long time (35-50 minutes) and then breaks. If I do a normal hg clone on my machines, it's quicker by an order of magnitude. Is it possible that the import fails because a certain revision takes too long to import into bzr and the server hence closes down the connection for inactivity? Shouldn't a keep-alive be sent in this case? Can someone of Launchpad staff do the import once manually?

(This might or might not be a bug.)

Question information

English Edit question
Launchpad itself Edit question
[LEGACY] Canonical WebOps Edit question
Last query:
Last reply:
gary 2011-08-26: Assigning to the losas for them to do a manual import.
Gary Poster (gary) said : #1

So far I have this information:
 - The suspicion is that in fact the whole branch, not just a revision, is taking a long time.
 - The timing to compare to Launchpad is "bzr branch" with bzr-hg installed (I tried doing this but got into a version snafu).
 - LOSAs may be willing/able to do a manual branch, but I don't have solid confirmation yet.

Michael Barnett (mbarnett) said : #2

I have re-scheduled an import of this branch to see if I can see if there is anything going on when it is timing out.

Michael Barnett (mbarnett) said : #3

This did not work. I will need to look into a sync.

Michael Barnett (mbarnett) said : #4

Sorry, a manual sync that is.

David Ames (thedac) said : #5

 Attempting a manual local import of

With version of bzr-hg on natty I run into this bug: using bzr-hg
bzr: ERROR: An inconsistent delta was supplied involving '<unknown>', 'hg:planet_sObjects.c4d_sGoals.c4d'
reason: Parent is not present in resulting inventory.

Testing with bzr-fastimport had different issues
Issued 3439 commands
17:04:13 Updating branch information ...
         branch openclonk now has 723 revisions and 1 tag
17:04:14 WARNING: Cannot import multiple branches into a standalone branch
17:04:14 WARNING: Not creating branches for these head revisions:
17:04:14 <email address hidden> = floating-point
17:04:14 devnull@localhost-20100801131354-kclviugroteveztp = norefs
17:04:14 <email address hidden> = stable-5.1
17:04:14 Updating the working tree for /home/thedac/bzr/openclonk ...
All changes applied successfully.
17:04:21 Imported 3436 revisions, updating 1 branch and 1 tree in 0:06:45

I then ran the latest branch of bzr-hg and this had a connection time out very similar to what we are seeing in LP
bzr: ERROR: [Errno None] connection ended unexpectedly

I will check with the BZR devs tomorrow

Gary Poster (gary) said : #6

Philipp, we are sorry, but you have encountered a bug in our mercurial support. I am told this is a non-trivial issue to address.

You can track the issue here: .

We apologize for the inconvenience.


Can you help with this problem?

Provide an answer of your own, or ask Philipp Kern for more information if necessary.

To post a message you must log in.