Mercurial branch import incomplete

Asked by Maarten Bezemer on 2011-08-07

I have created a request for an externa (Google code)l mercurial repository (default branch) import. It seemed to work, according to the log all changeset are retrieved (see http://launchpadlibrarian.net/76727591/maarten-bezemer-ganttproject-imported.log). But, in the end only the first 3 revision are available in the bazaar branch (https://code.launchpad.net/~veger/ganttproject/import). Subsequent imports 'think' everything is up-to-date and do nothing additional.

We do use (a lot) branches in the external repository, but I read that the default branch should be imported completely.

When I look at the avilable branches (only relevant onces shown):
$ hg heads
changeset: 611:30e76f027936
tag: tip
user: Maarten Bezemer
date: Sat Aug 06 20:04:21 2011 +0200
summary: Copied code formatter/style/template/etc from ganttproject project to other projects as well

changeset: 2:25bf1f28b048
user: Dmitry Barashev
date: Wed Jun 16 04:25:59 2010 +0400
summary: test branch

The 2nd branch is imported (changeset 2:25bf1f28b048) instead of the tip (changeset: 611:30e76f027936).

So, am I doing something wrong here, do I need to specicify somehow that the default (tip) branch needs to be imported?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Aaron Bentley
Solved:
2011-08-08
Last query:
2011-08-08
Last reply:
2011-08-08
Best Aaron Bentley (abentley) said : #1

This looks like a bug in bzr-hg

Maarten Bezemer (veger) said : #2

Thanks Aaron Bentley, that solved my question.