Branch stuck in "Updating branch..."

Asked by Colin Watson on 2011-07-13

I pushed changes to https://code.launchpad.net/~cjwatson/launchpad/dpkg-xz-support-619152 yesterday, but it's been stuck in the "Updating branch..." state ever since. Could somebody find out what's wrong with the branch scanner here? Thanks.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
Aaron Bentley Edit question
Last query:
2011-07-14
Last reply:
2011-07-28
Whiteboard:
Asking abentley to give us a nudge in the right direction, after which he might unassign himself.
Brad Crittenden (bac) said : #1

Colin you need to push a change up to that branch to get the scanner unstuck. Sorry for the inconvenience. I had a LOSA re-run the scanner but that didn't work.

Please try another push of a trivial change and let me know if it worked.

Colin Watson (cjwatson) said : #2

I tried pushing a trivial change (bzr commit --unchanged). Unfortunately, it doesn't seem to have had any effect.

Aaron Bentley (abentley) said : #3

This appears to be due to a MemoryError while attempting to scan the branch: OOPS-2021SMS7

Colin Watson (cjwatson) said : #4

Is there anything I can do about this, or will the LP team be able to disregard that problem while merging? I expect the deployment blockers will be gone in a couple of days.

Aaron Bentley (abentley) said : #5

This doesn't affect bzr's usage of the branch, just Launchpad's display of it. So merging should not be an issue.

There's nothing to be done for this specific branch, but you can file a bug that we're using too much memory. OTOH, bzr 2.4 will be landing soon, and that will improve the memory footprint, so perhaps you don't need to do anything.

Can you help with this problem?

Provide an answer of your own, or ask Colin Watson for more information if necessary.

To post a message you must log in.