Importing a GPG key doesn't seem to work

Asked by Bernhard Rosenkraenzer on 2011-06-19

Hi,
I'm trying to import my GPG key into launchpad.
The key ID is 2DD765E2 and the fingerprint is
A03A 7003 576D 9B41 3154 627A 5D58 D854 2DD7 65E2
(and I've entered it that way repeatedly), and I've made sure it is known to the Ubuntu keyserver - it's here:
http://keyserver.ubuntu.com:11371/pks/lookup?search=bero%40bero.eu&fingerprint=on&op=vindex

Am I doing something wrong, or is launchpad malfunctioning?

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2011-06-20
Last reply:
2011-06-20
Gary Poster (gary) said : #1

Hello Bernhard. Could you let us know a bit more about how it is not working? For instance, are you getting an error page? Are you not receiving the confirmation mail?

It kept saying it doesn't know about the key - same thing you get before the key server has processed the key.
It actually worked and imported the key fine today, not sure what the reason was. Probably one of:
- Launchpad didn't have access to the key even though the keyserver's web interface found it
- Launchpad doesn't like Arora (http://arora-browser.org/), I was using that yesterday while I was on a different box with Firefox today
Probably the server's logs can tell more.

The problem is solved for me, but nevertheless someone may want to look into it in case it's an incompatibility with Arora (and probably other browsers, given for all that matters Arora and Rekonq are the same)

Brad Crittenden (bac) said : #3

Hi Bernard,

If you were getting an error message from Launchpad like:

Launchpad could not import your OpenPGP key
 Did you enter your complete fingerprint correctly?
Is your key in the Ubuntu keyserver yet?
   You may have to wait between ten minutes (if you pushed
   directly to the Ubuntu key server) and one hour (if you pushed
   your key to another server).

then it is highly unlikely that there is a browser-related issue.

There would be no OOPS report generated so we don't have much to go on and no other information is logged in that situation.

Thanks for taking the time to give feedback but we'll have to wait for this problem to arise again.

Brad Crittenden (bac) said : #4

Problem is no longer reproducible.

Can you help with this problem?

Provide an answer of your own, or ask Bernhard Rosenkraenzer for more information if necessary.

To post a message you must log in.