Packaged remembered and in diff after delete

Asked by Philip Johnsson on 2011-04-14

I have uploaded and built opencv 2.1.0-maverick~ppa4 to my PPA (https://edge.launchpad.net/~philip5/+archive/extra) after I had an upload and deleted opencv 2.2.0-maverick~ppa1. The opencv 2.2.0-maverick~ppa1 is still there in some how but deleted. I get a "Available diffs" 2.2.0-maverick~ppa1 to 2.1.0-maverick~ppa4 against a deleted package. This also gives a "Failed to upload " error message as a package get rejected for being older than the deleted one.

DEBUG Considering changefile 11659/ubuntu/opencv_2.1.0-maverick~ppa4_i386.changes
DEBUG Finding fresh policy
INFO Processing upload opencv_2.1.0-maverick~ppa4_i386.changes
INFO Upload was rejected:
INFO python-opencv_2.1.0-maverick~ppa4_i386.deb: Version older than that in the archive. 2.1.0-maverick~ppa4 <= 2.2.0-maverick~ppa1
INFO Committing the transaction and any mails associated with this upload.

Upload log:
Uploading build 20110414-093411-2468031-PACKAGEBUILD-2474947 failed.

How can I get a permanent delete of opencv 2.2.0-maverick~ppa1 from history?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Philip Johnsson
Solved:
2011-04-14
Last query:
2011-04-14
Last reply:
2011-04-14
Philip Johnsson (philip5) said : #1

Just to be clear. I broke out opencv 2.2.0 to be a own it's own setup of packages naming it opencv2.2 2.2.0. Package suit opencv2.2 should remain as 2.2.0 (2.2.0-maverick~ppa2). And I try to keep opencv as 2.1.0-maverick~ppa4. It's packages of opencv and not opencv2.2 that I have problems with.

Julian Edwards suggests this article as an answer to your question:
FAQ #990: “Can I re-upload the same package sources?”.

Philip Johnsson (philip5) said : #3

Deleted all opencv packages again. Waited an hour and the uploaded a new bumped opencv 2.1.0-maverick~ppa5 version. Problem solved. I guess I uploaded the bump to soon after the delete.

Note for anyone wondering, I deleted my 2.2.0-maverick~ppa1 packages before they got published so no users would have downloaded anything.