Page not found from Launchpad link to possibly private bug 688733

Asked by Eliah Kagan

Bug 755579 is marked as a duplicate of bug 688733. At the page for bug 755579, I clicked the link to bug 688733 (in the yellow box that says "Remember, this bug report is a duplicate of..."). This gave me an "Error: Page not found" page, saying that "There’s no page with this address in Launchpad." That page provided error ID OOPS-1926S858 for reporting the problem.

The error message when manually entering a URL for bug 688733 is the same as the page for manually entering a URL for a clearly nonexistent bug (e.g. nonexistent bug 999999999). However, when I try to mark as being related to bug 688733 (using "Link existing bug"), it says "You are not allowed to link to private bug #688733." Dissimilarly, when I try to mark it as being related to nonexistent bug 999999999, it says "Not a valid bug number or nickname." This is why I suspect that bug 688733 is a private bug, even though attempting to browse to it or enter its URL does not inform me that it is.

Assuming bug 688733 really is a private bug, I understand that I am not permitted to access its page or mark a question as relating to it. However, for a private bug, when attempting to follow a link to it, a different error should (and except in this instance, always has) come up, saying that it is private so I'm not allowed to access it. Therefore, I believe the specific error I have seen in this case constitutes a malfunction.

Since not knowing the status of this bug or even if it really exists is blocking my work in helping with question, I am reporting this here in accordance with the instructions on the error page.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Curtis Hovey
Last query:
Last reply:
Revision history for this message
Best Curtis Hovey (sinzui) said :

Lp changed the rules of private bugs to look like a 404. This caused excessive confusion since the page still show you a link to the bug. Lp should state that the bug is private not provide a link.

Revision history for this message
Eliah Kagan (degeneracypressure) said :

Thanks Curtis Hovey, that solved my question.

Revision history for this message
Eliah Kagan (degeneracypressure) said :

Thanks for the prompt response and explanation for this situation. I'm glad this is being handled as a bug.

Revision history for this message
Mike (bild85) said :

Also affected me for a bug that was linked to another bug by the Apport retracing service:

The first bug I noticed is that the info box in the upper-right corner of the above bug contains the following text:
Duplicate of bug #733146
Convert to a question
Link a related branch
Link to CVE

Usually the "Duplicate of bug #XXXXXXX" provides a link to the linked bug, but in this case there is no link.

The second oddity I noticed is described in this question: that when I tried to look at the bug it was marked as the parent:
I get this page:
 "Lost something?
There’s no page with this address in Launchpad."

After finding this question I see that this is expected behavior; or at least that it is a known issue.

Revision history for this message
iMac (imac-netstatz) said :

I have had this happen twice this week due to the Apport retracing service marking my bug as a duplicate of a bug I cannot access.

It is nice to know there is a dupe, but it would have been even better to have identified it before creating/submitting a duplicate, and or be able to confirm that it is actually a valid duplicate and track status and help triage.

I now have at least two recent bugs marked as private duplicates, I suspect due to the personal data sometimes involved in evolution bugs. How do I track these?

Revision history for this message
Juozas Pocius (juozaspo) said :

this also affects me. The bug I tried to fix ages ago is Bug #757305 witch links to Bug number #757280 though this might be not a problem anymore. Though i could't confirm if it got fixed becouse of that.

Also this bug not marked public for quite few weeks so this must be a real problem.