Package available in multiple PPAs

Asked by Javier Collado on 2011-01-26

In the past I used to upload the same source package to multiple PPAs as a a trick to avoid waiting for the package to be built and then copy the package from one PPA to the other ones.

However, recently it seems that launchpad doesn't accept anymore to upload the same source package to a different PPA since dput returns the following error message:
Package has already been uploaded to ppa on ppa.launchpad.net

Since isn't yet possible to schedule a copy once the package is built (bug554621), I was wondering if there's any recommended way to do that aside from waiting and then manually copy the packages using the web interface.

Is there, maybe, any shortcut using launchpadlib?

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Max Bowsher
Solved:
2011-01-26
Last query:
2011-01-26
Last reply:
2011-01-26

This question was reopened

Best Max Bowsher (maxb) said : #1

The "Package has already been uploaded to ppa on ppa.launchpad.net" message you mention is coming from your local dput command, not Launchpad.

Use 'dput -f' or delete the <changes-base-name>.upload flag file left by the previous dput run.

That's interesting.

Previously I used different .dput.cf entries for each PPA and that created different upload files, while now I'm using "ppa:<team>/<ppa_name>" which creates a single upload file as you pointed out.

I think the '-f' flag will solve the problem. Thanks!

Thanks Max Bowsher, that solved my question.