branch content disappeared

Asked by Eli Osherovich

I have a small package on LP, called eol. The package currently contain two branches. One called "current" (belongs to "trunk" series) and another one called "oo" which is stacked upon "current". Today I decided to do a small re-organization: I renamed "current" into "old" and set its status to "abandoned". I also moved the other branch ("oo") into "trunk" series to make it the default branch. Now, the EOL's webpage correctly reports the both branches and their statuses, however, when I try to access the new "trunk" I get an error.

If I try to perform a branch from BZR I get the following error:
> bzr branch lp:eol
bzr: ERROR: Not a branch: "bzr+ssh://".

As you can see, for some reason, it tries to access the non-existent "current" branch (it was renamed to "old" and removed from "trunk" series).

If I try to see the content of "oo" branch via LP webpage (e.g., it says

The resource could not be found.

What is going on here? Is it a bug in LP? And most important one: have I lost my branch content?

Thank you.

Question information

English Edit question
Launchpad itself Edit question
[LEGACY] Canonical WebOps Edit question
Solved by:
Max Bowsher
Last query:
Last reply:
Revision history for this message
Max Bowsher (maxb) said :

Hi billi,

It is a bug in Launchpad that it does not update Bazaar stacked-on locations when branches are renamed. Your branch content has not been lost, it is just temporarily inaccessible until the pointer to the stacked-on branch is fixed.

I'll assign this question to the Launchpad administrators who can do this.

Revision history for this message
Max Bowsher (maxb) said :

Dear LOSAs, please execute your script for fixing branch stacking locations for branch lp:~eli-osherovich/eol/oo

Revision history for this message
Tom Haddon (mthaddon) said :

I found the branch and ran the script per the instructions, but the only output was:

2011-01-12 10:48:51 INFO Creating lockfile: /var/lock/launchpad-update-stacked-on.lock
2011-01-12 10:49:01 INFO Done

Can you confirm if this has done anything for you?

Thanks, Tom

Revision history for this message
Best Max Bowsher (maxb) said :

The things reported as failing in the initial question are working fine, so I suppose someone fixed it earlier. Odd.

Revision history for this message
Eli Osherovich (eli-osherovich) said :

I somehow removed all branches and re-committed them from a local copy on my computer. Now it is working.

It does not mean that there is no problem in LP. The problem still exists.

Thank you.