can no longer convert to question

Asked by Micah Gersten on 2010-10-28

There is a problem with hitting the timeout limit on converting to question. Before on edge it would fail, but on non-edge it would timeout but work. Now, the edge redirect removal is gone and I cannot convert to question:
See https://bugs.launchpad.net/launchpad-foundations/+bug/438116

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Deryck Hodge
Solved:
2010-11-03
Last query:
2010-11-03
Last reply:
2010-11-03
Gavin Panella (allenap) said : #1

Hi Micah,

Along with the loss of edge redirect removal is the loss of edge redirection, it appears. Try going straight to the page on the non-edge service. Hopefully that'll let people continue working until bug 438116 is fixed. Write back here if not; we may be able to increase the time-out for that page.

Gavin.

Deryck Hodge (deryck) said : #2

Yes, we can up the timeout for +create-question using feature flags and help Micah out. I can do this shortly if no one beats me to it.

Deryck Hodge (deryck) said : #3

Here's the feature flag we need. I couldn't catch a LOSA before ending my day.

# Raise +create-question to 15 seconds
hard_timeout pageid:BugTask:+create-question 1 15000

Deryck Hodge (deryck) said : #4

This has been applied to give a longer timeout. I based 15 seconds on my reading of the timeout reports, so if this doesn't work, please let me know.

Cheers,
deryck

Best Deryck Hodge (deryck) said : #5

As noted on IRC yesterday, there's just nothing we can do with raising the hard timeout. Anything greater than 20 seconds will starve app servers and anything over 30 is killed by haproxy with a could not connect to lp error. The 99% time for this page is >100 seconds. Unfortunately, there's no work around available. We'll have to have the bug listed above fixed to fix the issue.

Micah Gersten (micahg) said : #6

Thanks Deryck Hodge, that solved my question.