Mailing list gone and cannot be created

Asked by Jussi Pakkanen on 2010-10-14

I have filed a new bug as suggested here: https://answers.launchpad.net/malone/+question/58912

The exact details can be seen in that bug, but a quick recap is as follows:

- a user's out-of-office autoreplies start spamming bugs and the mailing list
- I disable the mailing list to stop spamming our users
- spamming user id is disabled by Launchpad moderators
- I try to re-enable the mailing list but it says "This team's mailing list could not be created. Please contact a Launchpad administrator for further assistance."

The mailing list archive is also gone.

The team mailing list page is https://launchpad.net/~cuneiform/+mailinglist .

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
[LEGACY] Canonical WebOps Edit question
Solved by:
Jussi Pakkanen
Solved:
2011-01-12
Last query:
2011-01-12
Last reply:
2011-01-10
Whiteboard:
https://wiki.canonical.com/InformationInfrastructure/OSA/LPHowTo/DeleteEmailFromArchive/ team/list: cuneiform message-ids: 722 724 725 726 727 728 729 73 731 732 737 742 747 752 756 762 767 772 772
Curtis Hovey (sinzui) said : #1

That was odd. I could not reactivate it. I could purge the old list. Try creating it again.

Jussi Pakkanen (jpakkane) said : #2

I recreated it and it's back up including the archive (unfortunately also all the spam messages are there).

I got an email asking me join the mailing list through some page in Launchpad. This is strange since when I checked it, I was already subscribed.

Have all old members been automatically resubscribed to the list?

Curtis Hovey (sinzui) said : #3

Yes, old memberships were subscribed, and the old archive was restored. "Purged" just resets Lp's knowledge of the list so that it can be recreated. Launchpad admins can delete spam messages from the archive if you can provide links to problem pages.

Jussi Pakkanen (jpakkane) said : #4

The spam messages can be seen on this page:

https://lists.launchpad.net/cuneiform/

They are the posts made by user daniel. The topmost one is this:

# Re: [Cuneiform] [Bug 640051] Re: Type mismatch: va_list and char*
    * From: daniel <640051@xxxxxxxxxxxxxxxxxx>, 2010/10/11

And the bottommost is this one:

# Re: [Cuneiform] [Bug 324256] Re: Strange symbols instead '-' in smart text output
    * From: daniel <324256@xxxxxxxxxxxxxxxxxx>, 2010/10/10

There are several of dozen identical spam messages in between.

Steve McInerney (spm) said : #5

they should all be removed now.

Cheers!
- Steve

Curtis, ta for the list! like huge sincere thanks! :-)

Jussi Pakkanen (jpakkane) said : #6

I still see them. For example this:

https://lists.launchpad.net/cuneiform/msg00772.html

Steve McInerney (spm) said : #7

That's ... surreal. I verified they were gone!!!
Leave it with us. Clearly the messages are being held somewhere else and being regenerated.

Jussi Pakkanen (jpakkane) said : #8

They are still there.

Tom Haddon (mthaddon) said : #9

I tried running the script to delete the messages but in each case it said it doesn't exist. I'll file a bug about this and link this question to it.

Jussi Pakkanen (jpakkane) said : #10

The message I linked to above has been purged. Thanks for that.

However there are still a bunch of them. They are at the bottom of this page, the ones by user daniel: https://lists.launchpad.net/cuneiform/

Tom Haddon (mthaddon) said : #11

Ok, I think that should now be it.

Thanks, Tom

Curtis Hovey (sinzui) said : #12

We need to delete more messages. Note that the instructions on /InformationInfrastructure/OSA/LPHowTo/DeleteEmailFromArchive/ were updated. I think the delete can just be run with the new message list

Team: cuneiform
Message-ids 730 736 738 739 743 744 745 746 749 750 751 753 754 755 757 759 760 761 763 764 765 766 768 769 770 771 771

If we have trouble again, use the deleted-messages.py to get the list of already deleted messages. regenerate the archive, the call delete for the old list and new list of message ids.

Jussi Pakkanen (jpakkane) said : #13

It is fixed now. Thanks.