Open PGP key not importing

Asked by Melissa Draper on 2006-07-23

When trying to import my pgp key, the process fails saying:

"Launchpad could not import your OpenPGP key."

and

"HTTP Error 500: OK at http://keyserver.ubuntu.com:11371/pks/lookup?search=0x940BDA96&op=get

Try again later or cancel your request."

When I did "gpg --send-key <key-id>" it sent the key to hkp server subkeys.pgp.net

This has been the case for ~15 hours now.

Question information

Language:
English Edit question
Status:
Answered
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Last query:
2006-07-27
Last reply:
2008-01-10
Diogo Matsubara (matsubara) said : #1

On Sun, Jul 23, 2006 at 05:20:02AM -0000, Melissa Draper wrote:
> New support request #1262 on Launchpad:
> https://launchpad.net/products/launchpad/+ticket/1262
>
> When trying to import my pgp key, the process fails saying:
>
> "Launchpad could not import your OpenPGP key."
>
> and
>
> "HTTP Error 500: OK at http://keyserver.ubuntu.com:11371/pks/lookup?search=0x940BDA96&op=get
>
> Try again later or cancel your request."

Hello Melissa,

we're investigating why the sync between the subkeys.pgp.net keyserver and
keyserver.ubuntu.com isn't working.

>
> When I did "gpg --send-key <key-id>" it sent the key to hkp server subkeys.pgp.net

As an workaround you might want to try:

$ gpg --keyserver keyserver.ubuntu.com --send-key <key-id>

If you need any extra help, please feel free to contact me in #launchpad at
irc.freenode.net

Cheers,

>
> This has been the case for ~15 hours now.
>

--
Diogo M. Matsubara

Melissa Draper (melissa) said : #2

Sorry it's taken so long to comment back on this. I took the work-around option in the end, just hadn't gotten back to reporting back.

Providing this issue hasn't already been resolved, here is some more information:

- The work-around worked (upload direct to keyserver.ubuntu.com)
- The issue isn't/wasn't isolated to the pgp.net server, it also affected synching with pgp.mit.edu server.

Christian Reis (kiko) said : #3

Thanks for your feedback, I've incorporated your hints into an improved set of GPG and CoC-related pages that should be rolled out this week.

I also can't import my fingerprint and keep on getting "Launchpad could not import your OpenPGP key" everytime I do. This is a valid fingerprint the Launchpad rejects. The key has also been manually uploaded into keyserver.ubuntu.com but it still fails in accepting it. Been doing this every hour for the past 10 hours.
Please give us updates.
Dax Solomon Umaming

Diogo Matsubara (matsubara) said : #5

Hello Dax,

which key you're trying to upload to launchpad.net?

If you're still experiencing this problem, I'd suggest you to file a new support request[1] and assign it to me. Also feel free to contact me in #launchpad @ irc.freenode.net. I'm usually there from 12:00 UTC to 21:00 UTC.

[1] https://launchpad.net/products/launchpad/+addticket

Thank you,

matsubara

I should've reported sooner, but everything went well the next day. I wasn't able to file for a bug though. Anyway, thanks for your help Diogo!

W. Scott Lockwood III (wsl3) said : #7

I'm getting a similar error to Dax's trying to get it to accept the signed code of conduct. The error I get is: Please fix the problems below and try again.

(7, 9, 'No public key')

The page I'm getting the error at is: https://launchpad.net/codeofconduct/1.0.1/+sign

I have successfully uploaded several keys - could that be part of the issue?

Diogo Matsubara (matsubara) said : #8

Hello Scott,

I suggest you file a new question[1] and assign it to me. Also feel free to contact me in #launchpad @ irc.freenode.net. I'm usually there from 11:00 UTC to 21:00 UTC.

Please describe in the question the steps you're taking to upload sign the code of conduct, the key you're using to sign it and paste the signed code of conduct.

[1] https://launchpad.net/launchpad/+addquestion

Thank you,

matsubara

Can you help with this problem?

Provide an answer of your own, or ask Melissa Draper for more information if necessary.

To post a message you must log in.