unable to push code from MacOS 10.5, ssh problem?

Asked by Sharad Shanbhag on 2010-08-18

Hi,

I'm trying to push an initial branch of code to launchpad.

I've setup the ssh keys and use the launchpad-login bzr command successfully:

$ bzr launchpad-login sshanbhag --verbose
Launchpad user ID exists and has SSH keys.
Launchpad user ID set to 'sshanbhag'.

I then try to push the working branch to launchpad:

$ bzr push lp:~sshanbhag/tytology/release_1.0

A window pops up and asks for a password. However, when I provide the password I used when creating the ssh key, login fails and I receive this message:

Permission denied (publickey).
bzr: ERROR: Connection closed: Unexpected end of message. Please check connectivity and permissions, and report a bug if problems persist.

the permissions on the id_rsa.pub file are:

-rw------- 1 sharad staff 402 Aug 18 14:21 id_rsa.pub

any suggestions to resolve this issue will be most welcome!

thanks.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Sharad Shanbhag
Solved:
2010-08-25
Last query:
2010-08-25
Last reply:
2010-08-24

if you are using different ssh keys please check your ~/.ssh/config

mine looks like that for launchpad:
## Launchpad key
Host bazaar.launchpad.net
  User thopiekar
  IdentityFile /home/thopiekar/.ssh/id_rsa.1

Sharad Shanbhag (sshanbhag) said : #2

Thomas,

thanks for the response. I had tried what you suggest already and it didn't solve the problem I was having.

As of today (25 Aug, 2010), things are working. I did two things, but did them simultaneously, so I cannot say which action solved my problem.

1) I generated a new ssh key using dsa encryption (instead of rsa encryption that I was using originally) and uploaded this key to launchpad. I also modified the ~/.ssh/config file to reflect this change. The instructions for this I adapted from here: http://wiki.openlp.org/Configuring_SSH_Keys_on_Linux_and_Mac_OS_X

2) I followed the tip given here ( http://blog.jbglenn.net/2010/03/how-to-add-ssh-private-key-to-apple.html ) to add passphrases from ssh to the Apple Keychain

Then:

$ bzr launchpad-login --verbose
Launchpad user ID exists and has SSH keys.
sshanbhag

$ bzr push lp:~sshanbhag/hpsearch/testrelease

The authenticity of host 'bazaar.launchpad.net (91.189.90.11)' can't be established.
RSA key fingerprint is 9d:38:3a:63:b1:d5:6f:c4:44:67:53:49:2e:ee:fc:89.
Are you sure you want to continue connecting (yes/no)? yes

Warning: Permanently added 'bazaar.launchpad.net,91.189.90.11' (RSA) to the list of known hosts.

Created new branch.

Success!