bzr: ERROR: No such file: '/srv/'

Asked by Keith Hughitt


For some reason, the development trunk on Launchpad for our team has become corrupted. Attempting to push or pull to the branch results in an error message:

"bzr: ERROR: No such file: '/srv/'"

So far we have tested access from two different machine with the same result. Furthermore, attempting to view changes associated with the branch now result in a server error.

The problematic branch is:

Finally, I also tried deleting the branch on Launcpad in order to re-upload it (, however, Launchpad will not allow this, complaining:

"This branch cannot be deleted as it has 5 branches sharing revisions."

Unfortunately it does not specify which five branches are dependent on it, and even if it had, I'm not certain that they would all be owned by active users who could delete their own branches.

Do you have any suggestions? Any advice would be appreciated.


Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Keith Hughitt
Last query:
Last reply:
Revision history for this message
Max Bowsher (maxb) said :
Revision history for this message
Max Bowsher (maxb) said :

In some mysterious and unknown way, one of the packs and its indices has been moved to obsolete_packs but is still listed in pack-names. The branch can be mended by moving them back.

Something like this ought to do the trick.

mkdir /tmp/mountpoint
sshfs /tmp/mountpoint
cd /tmp/mountpoint
mv .bzr/repository/obsolete_packs/2b08137c9cd4e7edb0b56944e678d55c.pack .bzr/repository/packs/
mv .bzr/repository/obsolete_packs/2b08137c9cd4e7edb0b56944e678d55c.*ix .bzr/repository/indices/
fusermount -u /tmp/mountpoint

Revision history for this message
Keith Hughitt (keith-hughitt) said :

Hi Max,

Thanks for taking the time to respond. I tried your above suggestion, but when I attempt to mount the branch using sshfs, I get an error "read: Connection reset by peer." I tried a couple suggestions on the web (removing known_host entry and making sure fuse is installed) but still no luck.

I've never used sshfs before. Any suggestions? I tried using SSH to connect to Launchpad normally (not sure if that is actually possible but it seemed likely since you could mount a folder using a tool called "sshfs" but that did not work with the above URL).

Revision history for this message
Keith Hughitt (keith-hughitt) said :


Including my username in the bzrssh command enabled that to work. I followed the above steps, however, the problem still persists, e.g.:

bzr branch

"bzr: ERROR: No such file: '/srv/'"

The offending file (2b08137c9cd4e7edb0b56944e678d55c.rix) exists in the obsolete packs directory. Should I move that to the location it is expecting to find it in? How about the other .*ix files?

Thanks again for your help.

Revision history for this message
Max Bowsher (maxb) said :

Hi Keith,

Please look again at the commands I suggested - they already include commands to move that file, and others, out of obsolete_packs to where they are expected.

Revision history for this message
Keith Hughitt (keith-hughitt) said :

Oops. I somehow missed the second mv command. That worked great. Thanks for your help, Max!

Revision history for this message
Brad Crittenden (bac) said :

This problem just happened to me with a bzr repository not hosted at Launchpad. I was able to move the pack and indices files and recovered.