amd64 build failure for lucid despite successfull completion

Asked by nachiket

I'm not sure why my amd64 build is failing. The i386 build completes successfully. The Karmic builds were also fine.
I updated the package for Lucid and started seeing this behavior. There are no errors in the buildlog.

Any help is appreciated.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Solved by:
Max Bowsher
Last query:
Last reply:
Revision history for this message
Best Max Bowsher (maxb) said :

The error is these lines at the end of the build log:

Function `CKTdltNNum' implicitly converted to pointer at /build/buildd/spice3f5-9ubuntu1/src/lib/dev/ltra//ltraset.c:277

Our automated build log filter detected the problem(s) above that will
likely cause your package to segfault on architectures where the size of
a pointer is greater than the size of an integer, such as ia64 and amd64.

This is often due to a missing function prototype definition.

Since use of implicitly converted pointers is always fatal to the application
on ia64, they are errors. Please correct them for your next upload.

More information can be found at:

This message is a warning on some architectures and prior to lucid, but is an error on 64 bit architectures from lucid onwards.

Revision history for this message
nachiket (nachiket) said :

Thanks Max Bowsher, that solved my question.