Told I proposed a branch for merging weeks after it was merged

Asked by Jonathan Lange


I just received an email telling me that I had proposed merging lp:~jml/zope.testing/subunit-error into lp:~vcs-imports/zope.testing/trunk. Thing is, I proposed that merge and had it merged weeks ago.

I'm not sure whether this is a bug or a temporary operational glitch. I would love to know why I got it though, and whether similar bogus emails are being sent out.

The email is included below.


Delivered-To: <email address hidden>
Received: by with SMTP id t14cs200467mur;
        Tue, 4 May 2010 03:33:54 -0700 (PDT)
Received: from (localhost [])
 by (Postfix) with ESMTP id CBAF12E857E
 for <email address hidden>; Tue, 4 May 2010 11:32:34 +0100 (BST)
Content-Type: text/plain; charset="utf-8"
MIME-Version: 1.0
Content-Transfer-Encoding: quoted-printable
X-Launchpad-Message-Rationale: Owner
X-Launchpad-Notification-Type: code-review
X-Launchpad-Branch: ~jml/zope.testing/subunit-error
In-Reply-To: <email address hidden>
Reply-To: <email address hidden>
Message-Id: <email address hidden>
X-Launchpad-Project: zope.testing
To: <email address hidden>
From: Jonathan Lange <email address hidden>
Subject: [Merge] lp:~jml/zope.testing/subunit-error into
Date: Tue, 04 May 2010 10:32:34 -0000
Sender: <email address hidden>
Errors-To: <email address hidden>
Precedence: bulk
X-Generated-By: Launchpad (; Revision="None";
 Instance="initZopeless config overlay"
X-Launchpad-Hash: 7a22ecda6d45ca89fa56e9fd69ab28e50de8579a

Jonathan Lange has proposed merging lp:~jml/zope.testing/subunit-error into=

Requested reviews:
  VCS imports (vcs-imports)
Related bugs:
  #560259 Subunit output formatter doesn't handle layer setup errors

This patch makes the subunit output formatter handle error() messages.
-- =
You are the owner of lp:~jml/zope.testing/subunit-error.

Question information

English Edit question
Launchpad itself Edit question
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Robert Collins (lifeless) said :

I think they are; I just got one for bzrtools - though that branch is
still 'needs review', so not totally useless.

Revision history for this message
Jonathan Lange (jml) said :

The branch lp:~jml/zope.testing/subunit-error has a strange error message. If I recall aright, it never worked successfully as a branch because I pushed up a 2a branch that tried and failed to stack on an old-format import.

The error message now is "Branch references are not allowed for branches of type Hosted." I don't think that was the error message then, but I cannot be certain.

Revision history for this message
Robert Collins (lifeless) said :

Thumper says 'jobs that couldn't run before are being run now' and
that it should be a fairly small number in this situation.

Can you help with this problem?

Provide an answer of your own, or ask Jonathan Lange for more information if necessary.

To post a message you must log in.