Parrot import fails with StrictCommitError: Tree is unclean

Asked by Ronald Blaschke on 2010-04-25

Parrot's import (https://code.launchpad.net/~parrot-dev/parrot/trunk) fails with the following message. Could you please have a look?

2010-04-21 08:19:46 WARNING N changeset 45841
Traceback (most recent call last):
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/scripts/code-import-worker.py", line 82, in <module>
    sys.exit(script.main())
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/scripts/code-import-worker.py", line 77, in main
    return import_worker.run()
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/lp/codehosting/codeimport/worker.py", line 434, in run
    return self._doImport()
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/lp/codehosting/codeimport/worker.py", line 518, in _doImport
    self.importToBazaar(foreign_tree, bazaar_branch)
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/lp/codehosting/codeimport/worker.py", line 496, in importToBazaar
    foreign_directory, "-SC", "%s::" % last_commit, bzr_directory)
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/lp/codehosting/codeimport/worker.py", line 513, in _runToBaz
    totla.totla(config, self._logger, config.args, SCM.tree(source_dir))
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/cscvs/cmds/totla.py", line 253, in totla
    take_action(apply, revision, target_tree, strict, logger)
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/cscvs/cmds/totla.py", line 286, in take_action
    revision, logger=logger, strict=strict, summarize=apply.summary)
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/cscvs/bzr.py", line 159, in commitWithAutomaticLog
    self._checkTreeIsClean()
  File "/srv/importd.launchpad.net/production/launchpad-rev-9193/lib/cscvs/bzr.py", line 184, in _checkTreeIsClean
    raise StrictCommitError(self)
cscvs.bzr.StrictCommitError: Tree is unclean: u'/srv/importd.launchpad.net/data/worker-for-branch-23526/bzr_branch'
Import failed:
Traceback (most recent call last):
Failure: twisted.internet.error.ProcessTerminated: A process has ended with a probable error condition: process ended with exit code 1.

Question information

Language:
English Edit question
Status:
Solved
For:
Launchpad itself Edit question
Assignee:
No assignee Edit question
Solved by:
Michael Hudson-Doyle
Solved:
2010-05-02
Last query:
2010-05-02
Last reply:
2010-04-25

This is my fault, it affects most imports that have been upgraded at some stage.

A temporary fix is easy when an admin gets online, and a real fix not too much harder...

Ronald Blaschke (rblasch) said : #2

Thanks Michael Hudson, that solved my question.