Ladon deploying with nginx trouble

Asked by Alexey Ustinnikov on 2016-02-10

I want to use soap11 interface and it's ok, when i do that locally. I'm sending test soap request from suds and there are no problems. But when I'm deploying, put my app under nginx and do test soap request on soap11 method then I'm getting this error:
Exception: (405, 'Requests for TDMethods soap11 interface must be posted'). I think this problem is that somehow POST is changed to GET after nginx and that is why ladon raise the error. Can anyone help, maybe anyone have good nginx configuration for doing that?

Question information

Language:
English Edit question
Status:
Solved
For:
ladon Edit question
Assignee:
No assignee Edit question
Solved by:
Alexey Ustinnikov
Solved:
2016-02-10
Last query:
2016-02-10
Last reply:
2016-02-10
jsgaarde (jakob-simon-gaarde) said : #1

I havn't tried with nginx ever, only Apache2. That being said, I can't imagine why it wouldn't work since the controlling layer is WSGI, not the webserver.

I'll try this later today I think.

/ Jakob

Alexey Ustinnikov (gr4k) said : #2

I've solved this problem. But It's not good: I've removed redirect from http to https.