How to invoke the applet from command-line?

Asked by karatedog on 2011-09-16

Indicator icon won't appear in 11.04, have to use a workaround using "gsetting" to enable ['all'] systray icons. However this will render other icons useless, so I would like to run the applet from command line.

Question information

Language:
English Edit question
Status:
Solved
For:
L2TP over IPsec VPN Manager Edit question
Assignee:
No assignee Edit question
Solved by:
Werner Jaeger
Solved:
2011-09-17
Last query:
2011-09-17
Last reply:
2011-09-17
Best Werner Jaeger (werner-jaeger) said : #1

Unfortunately this applet can only run as a system tray icon. Only the connection editor has a standalone graphical user interface that you can start with the command line shown below:
L2tpIPsecVpn startConnectionEditor

I've tried it on 11.04 Beta 1 and there was no need to apply the "gsetting" workaround !

You could also try to append L2tpIPsecVpn to the end of the default list as shown below:
gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Mumble', 'Wine', 'Skype', 'hp-systray', 'L2tpIPsecVpn']"

Hope this helps.

Cheers
 Werner

Werner Jaeger (werner-jaeger) said : #2

Sorry, I've a typo in my answer #1.

Of course i meant 11.10 Beta 1 and not 11.04 Beta 1!

karatedog (karatedog) said : #3

Thanks, it works, I tried to enable it by the name of "l2tp-ipsec-vpn" which failed.

Ubuntu 11.10 Beta has Unity 3.8.18 at least, in which this bug has been fixed.

karatedog (karatedog) said : #4

Thanks Werner Jaeger, that solved my question.