problems selecting a file

Asked by Oier Mees on 2010-05-23

Hi there,
First of all, congrats because I think that kupfer is awesome and has a very big potential.
My problem is that I am unable to select a file. When I click a file in nautilus, for instance an image, and then in kupfer select ctrl+G nothing happens. Besides, I configured a "Show with Selection" shortcut (ctrl+alt+g) and it works with text but not with files.
I use ubuntu 10.04 and nautilus-elementary, could this be the reason ?
Many thanks,
Oier Mees

Question information

Language:
English Edit question
Status:
Solved
For:
kupfer Edit question
Assignee:
No assignee Edit question
Solved by:
X
Solved:
2010-05-23
Last query:
2010-05-23
Last reply:
2010-05-23

Hi. I don't know what nautilus-elementary is, but if it doesn't use nautilus' extensions, then that could be the problem. Notice that you have to restart nautilus after you install kupfer if you want the nautilus plugin to work. If Kupfer's nautilus plugin loads, the following will be part of nautilus' output to the termnnal (or to the file ~/.xsession-errors): "Initializing KupferSelectionProvider"

Oier Mees (oier) said : #2

Thanks Ulrik Sverdrup, that solved my question.

Oier Mees (oier) said : #3

Oops I haven't restarted nautilus, now it works, great! :-)
But it's strange because I haven't found that string in the ~/.xsession-errors file...
SInce it works, many thanks!

perezxolote (perezxolote) said : #4

Its not working for me. Using Kupfer from PPA on ubuntu 11.04. I looked for the string in ~/.xsession-errors file and it is not there. I also restarted nautilus after installing Kupfer (not directly but I restarted my computer many times since). Also using nautilus elementary.
What can I do to find out what is wrong?
Best,
Adrián

perezxolote (perezxolote) said : #5

Hi,

ok, I found out what was wrong with my kupfer-installation: the package python-nautilus was missing. Curiously enough it is not marked as a dependency in Ubuntu but just as a recommended package. However, the problem now is that, despite 'selected file' is working, I can not make any other operation with Kupfer any more. When I hit 'super-space' the kupfer-interface is appearing but then it doesn't respond to keyboard input. Any ideas?
It would be nice to get an answer this time.

All the best,
Adrián

perezxolote (perezxolote) said : #6

Ok, this one was not so tough to work out: after logging out-in the session everything worked fine.

Thank's for this really great software!

 (By the way: I really don't understand how this already available technology is not implemented in unity's shell. Software like Kupfer and Gnome-do are light-years ahead in terms of keyboard command of the desktop).

kudos,

Adrián