<Super> Space shortcut

Asked by Matheus Pacheco de Andrade on 2010-05-10

I can't get to use my keybinding with Kupfer when in Unity environment. Will try Gnome-Do later, but kupfer is preferred in a netbook for weight issues. Is there any way to make keybindings work or is it still not implemented?
Thank You.

Question information

Language:
English Edit question
Status:
Solved
For:
kupfer Edit question
Assignee:
No assignee Edit question
Solved by:
Matheus Pacheco de Andrade
Solved:
2010-05-10
Last query:
2010-05-10
Last reply:
2010-05-10

This question was reopened

I'm the maintainer of the keybinder library, maybe I can help better than the unity devs. 1) You must have python-keybinder version at least 0.1.1, 0.1.0 has a bug so it won't work. 2) If you have that, find out if the Unity system supports XKB (an X extension). It is possible keybinder fails if XKB is unavailable. 3) Otherwise check conflicting keys, check Kupfer's output (does it say successfully bound or not?)

Thank you for the interest, Ulrik.
Now that I went back to Unity with Kupfer's notification icon turned on I got to tweak a little bit with the keybindings, I got to associate it successfully with Ctrl+Alt+Space (python leybinder is 0.1.1 and I think xkb works, since it associates with another keyset), but I just can't get Kupfer to "read" when I press <Super L> alone. But it happened before, I am sure it is something I am doing wrong.

I see what you mean. The new "smart" keybinding configuration in Kupfer doesn't support binding only modifiers, that is by design, but I didn't anticipate this use case (I guess Super is the only key you can spare in that way). You can work around it by editing kupfer's config file manually (while kupfer is quit), entering the keybinding as Super_L I am unsure if we will change kupfer to allow single modifier activation, we'd need some changes to the configuration interface.

(I stole the question! I moved it from project unity -> project kupfer.. I hope everyone agree that it belongs here..)

It really belongs here.
And... I really don't wanna use Super_L as the single keybind, I tend to use Super_L+Space, but - in the key configuration window - Super_L is never recognized. I press Ctrl, I press Alt and they show there. I press any other thing and it shows there, but not Super_L - or for that matter Super_L plus any other key *if Super is pressed first*.
If I first press Ctrl or Alt, Kupfer recognizes Super properly, but not Super alone.
And if I gedit kupfer.cfg to <Super_L>Space, it binds to Space alone.

All this behaviour in Unity. In regular Netbook Edition or full Gnome desktop it goes perfectly right.

Now it is solved. Mutter was allocating Super for something I couldn't understand. I unset it and Kupfer was a doll again.
Thank you Ulrik.

The reason I though you wanted a modifier-only keybinding is that the key is called "Super_L" when used as just one key, but <Super> when used as a modifier. :-)

(So "<Super_L>Space" should have been "<Super>space")

Tobias Bradtke (webwurst) said : #8

I'm using Unity on Maverick Beta and can't use <super>space as a key binding. It seems <super>+<number> is used by Unity für application switching. <super>space seems not to be used, but is not recognized by Kupfer.

Can this be solved?