component definition box is mutual for two different units

Asked by Novak Tamas on 2015-10-08

I define a MCU component in Part Lib Editor. I make a component of two different units: unit A for GPIO's, unit B for power. In properties I've checked "all unit are not interchangable", pins are really unique for two units (I can switch on top dropdown which to see). But when I draw a rectangle for unit A, this box is drawn also for unit B.
As they have very different number of pins, the mutual container box is not fine. Is it a bug or not?

Application: kicad
Version: (2015-09-15 BZR 6201, Git 37c8462)-product release build
wxWidgets: Version 3.0.2 (debug,wchar_t,compiler with C++ ABI 1009,GCC 5.2.0,wx containers,compatible with 2.8)
Platform: Windows 7 (build 7601, Service Pack 1), 32 bit, Little endian, wxMSW
Boost version: 1.57.0
         USE_WX_GRAPHICS_CONTEXT=OFF
         USE_WX_OVERLAY=OFF
         KICAD_SCRIPTING=ON
         KICAD_SCRIPTING_MODULES=ON
         KICAD_SCRIPTING_WXPYTHON=ON
         USE_FP_LIB_TABLE=HARD_CODED_ON
         BUILD_GITHUB_PLUGIN=ON

Question information

Language:
English Edit question
Status:
Solved
For:
KiCad Edit question
Assignee:
No assignee Edit question
Solved by:
Maciej Suminski
Solved:
2015-10-09
Last query:
2015-10-09
Last reply:
2015-10-09
Best Maciej Suminski (orsonmmz) said : #1

Hi Tamas,

In the rectangle options (available in the right-click context menu in the symbol editor), you may uncheck 'Common to all units in components' checkbox. Perhaps it should be disabled by default, when a component has the attribute 'units are not interchangeable' selected.

Regards,
Orson

Novak Tamas (novak-7) said : #2

Thanks Maciej SumiƄski, that solved my question.

Novak Tamas (novak-7) said : #3

Hi, Orson,
this is one more case where I thought having a bug..but I simply didn't know what to do.
I was cautious, not reporting bug, but only placing a question:))
The same problem is with component name and reference (they are the same place at both units), but that is not a big deal.
Thanks!!!