Verify Keystone with Curl

Asked by kimimaru on 2012-03-20

I'm a newcomer in Openstack

I tried to install keystone with "apt-get install keystone"

After installation, I modified the keystone.conf listed later

I typed "curl http://0.0.0.0:35357" to verify the installation, but I got the message as following:

{"IdentityFault": {"message": "Unhandled error", "code": "500", "details": "Template u'/usr/keystone/content/admin/version.json.tpl' not found at line 0 column 0"}}

Did I config something wrong ? How can I solve this problem?

* *************************keystone.conf start ********************
[DEFAULT]
# Show more verbose log output (sets INFO log level output)
verbose = False

# Show debugging output in logs (sets DEBUG log level output)
debug = False

# Which backend store should Keystone use by default.
# Default: 'sqlite'
# Available choices are 'sqlite' [future will include LDAP, PAM, etc]
default_store = sqlite

# Log to this file. Make sure you do not set the same log
# file for both the API and registry servers!
log_dir = /var/log/keystone
log_file = keystone.log

# List of backends to be configured
backends = keystone.backends.sqlalchemy
#For LDAP support, add: ,keystone.backends.ldap

# Dictionary Maps every service to a header.Missing services would get header
# X_(SERVICE_NAME) Key => Service Name, Value => Header Name
service-header-mappings = {
        'nova' : 'X-Server-Management-Url',
        'swift' : 'X-Storage-Url',
        'cdn' : 'X-CDN-Management-Url'}

# Address to bind the API server
# TODO Properties defined within app not available via pipeline.
service_host = 0.0.0.0

# Port the bind the API server to
service_port = 5000

# Address to bind the Admin API server
admin_host = 0.0.0.0

# Port the bind the Admin API server to
admin_port = 35357

#Role that allows to perform admin operations.
keystone-admin-role = Admin
#Role that allows to perform service admin operations.
keystone-service-admin-role = KeystoneServiceAdmin

#Tell whether password user need to be hashed in the backend (2010-03-20)
hash-password = True

[keystone.backends.sqlalchemy]
# SQLAlchemy connection string for the reference implementation registry
# server. Any valid SQLAlchemy connection string is fine.
# See: http://bit.ly/ideIpI
sql_connection = mysql://keystone:P@ssw0rd@192.168.1.28/keystone
backend_entities = ['UserRoleAssociation', 'Endpoints', 'Role', 'Tenant',
                    'User', 'Credentials', 'EndpointTemplates', 'Token',
                    'Service']

# Period in seconds after which SQLAlchemy should reestablish its connection
# to the database.
sql_idle_timeout = 30

[pipeline:admin]
pipeline =
        urlrewritefilter
        admin_api

[pipeline:keystone-legacy-auth]
pipeline =
         urlrewritefilter
         legacy_auth
         service_api

[app:service_api]
paste.app_factory = keystone.server:service_app_factory

[app:admin_api]
paste.app_factory = keystone.server:admin_app_factory

[filter:urlrewritefilter]
paste.filter_factory = keystone.middleware.url:filter_factory

[filter:legacy_auth]
paste.filter_factory = keystone.frontends.legacy_token_auth:filter_factory

[filter:legacy_auth]
paste.filter_factory = keystone.frontends.legacy_token_auth:filter_factory

#[filter:d5_compat]
#paste.filter_factory = keystone.frontend.d5_compat:filter_factory

[filter:debug]
paste.filter_factory = keystone.common.wsgi:debug_filter_factory

#[filter:RAX-KEY-extension]
#paste.filter_factoryi = keystone.contrib.extensions.service.raxkey.frontend:filter_factory
* *************************keystone.conf end ********************

Question information

Language:
English Edit question
Status:
Solved
For:
OpenStack Identity (keystone) Edit question
Assignee:
No assignee Edit question
Solved by:
Joseph Heck
Solved:
2012-03-27
Last query:
2012-03-27
Last reply:
2012-03-23
Deepak Garg (deepak.garg) said : #1

There was an issue with that curl command in previous versions of Keystone.
Its fixed in the trunk version.
Its better to try the trunk version now. Its much stable compared to the previous versions.

$ git clone https://github.com/openstack/keystone.git
$ cd keystone
$ python setup.py develop

Hope it helps

Best Joseph Heck (heckj) said : #2

Deepak is quite correct, this is an issue with the previous version. The trunk is about to be cut as a release candidate (today, hopefully) - I recommend getting the essex release (or trunk, a Deepak describes above) and trying that instead.

kimimaru (cutekimimaru) said : #3

Thanks Joseph Heck, that solved my question.