Dependency is not satisfiable : python (>=2.7)

Asked by Alexander Dominic on 2012-07-19

I get the follwing error when try to install keryx

Dependency is not satisfiable : python (>=2.7).

using ubuntu 12.04

 when issue the command python the result is

Python 2.7.3 (default, Apr 20 2012, 22:44:07)
[GCC 4.6.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.

Question information

English Edit question
Keryx Edit question
No assignee Edit question
Last query:
Last reply:
Craig (craig-st) said : #1

I"m having the same problem.

Craig (craig-st) said : #2

Additional info:

Forcing install using dpkg --force-depends-version:
>sudo dpkg --force-depends-version -i keryx_1.0-public21_all.deb
Selecting previously unselected package keryx.
(Reading database ... 286371 files and directories currently installed.)
Unpacking keryx (from keryx_1.0-public21_all.deb) ...
dpkg: keryx: dependency problems, but configuring anyway as you requested:
 keryx depends on python (<< 2.7); however:
  Version of python on system is 2.7.3-0ubuntu2.
Setting up keryx (1.0-public21) ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...

And then, trying to run the installed package:
Traceback (most recent call last):
  File "/usr/bin/keryx", line 60, in <module>
    from keryx import AboutKeryxDialog, keryxconfig
ImportError: No module named keryx

Chris Oliver (excid3) said : #3

Hey Craig,

I'm not actively developing this anymore, but one solution is that you can download the source and extract it and run manually instead.

Craig (craig-st) said : #4

Just saw the bug report. Thanks for getting back to me, Chris.

Chris Oliver (excid3) said : #5

If you know of anyone who might like to take ownership of this project, please send them my way. :)

Can you help with this problem?

Provide an answer of your own, or ask Alexander Dominic for more information if necessary.

To post a message you must log in.