Is there anyway to keep things docked in the system tray so they're always there?

Asked by Johnny on 2013-08-16

Is there anyway to keep things docked up in the system tray forever so they're always there?

Question information

Language:
English Edit question
Status:
Solved
For:
Inactive kdocker (moved to https://github.com/user-none/KDocker) Edit question
Assignee:
No assignee Edit question
Solved by:
Johnny
Solved:
2013-08-17
Last query:
2013-08-17
Last reply:
2013-08-17
John Schember (user-none) said : #1

Between restarts, sort of. You can create a startup entry (depends on the desktop) to auto start kdocker with your desired apps.

Johnny (ohai) said : #2

I'm using the Elementary OS Luna distro, it uses Ubuntu 12.04. There is a startup app in the system settings. What would I enter to create a startup entry? It asks for Name, Command, Comment. What would be the command? Thanks.

John Schember (user-none) said : #3

> What would be the command?

Something like:

kdocker command_to_run

or

/full/path/to/kdocker /full/path/to/command/to/run

For example:

kdocker /usr/bin/gedit

Johnny (ohai) said : #4

Thanks. That does work but the set icon doesn't show upon a restart, it just shows the default icon. Also on some apps I get this error: http://i.imgur.com/Rdb9qpE.jpg Is there anyway to make it 10 seconds instead of 5 seconds? I'm using Kdocker 4.5 btw, as that's what was in the software center. Does Kdocker 4.8 fix any of these issues? Thanks once again for your help.

Johnny (ohai) said : #5

I figured out the icon issue:

kdocker -i "/usr/share/icons/Circles/typefilename.png" /usr/bin/typeappnamehere

Used that for the command and it works on startup with the icon I want. Yay!

Does the 5 seconds issue in the image above have to do with Elementary OS/Ubuntu's own parameters? I'll look into it...

Johnny (ohai) said : #6

Figured out the time issue:

kdocker -d 30 -i "/usr/share/icons/Circles/typefilename.png" /usr/bin/typeappnamehere

-d 30(or however many seconds you want to give it time to open, 5 seconds is the default)

In terminal type: kdocker -h for more options .

 Thanks once again.

Johnny (ohai) said : #7

Thanks.