web app icons in tray aren't updated

Asked by Pedro Bessa on 2011-01-07

I use Peppermint Ice, Chromium, imo, Seesmic and KDocker. I create shortcuts to imo and Seesmic in desktop with Chrome, then add "kdocker " after "Exec=" in both shortcut files, then put the shortcut in Peppermint Ice's autostart folder. So, imo and Seesmic autostart and autodock. When I double-click a shortcut without kdocker, as the page loads, the icons change in top-left. When I double-click a shortcut with kdocker, as the page loads, the icons don't change in top-left nor tray and the first icon is the icon that remains. Usually, the first icon and icon that remains is a Chromium's icon or a blank page.

Question information

Language:
English Edit question
Status:
Solved
For:
Inactive kdocker (moved to https://github.com/user-none/KDocker) Edit question
Assignee:
No assignee Edit question
Solved by:
Pedro Bessa
Solved:
2011-01-07
Last query:
2011-01-07
Last reply:
2011-01-07
Pedro Bessa (deltrem1984) said : #1

If the app being docked's icon changes in top left, change the app being docked's icon in tray. Thanks!

Pedro Bessa (deltrem1984) said : #2

I have just double-clicked imo and Seesmic's shortcuts, but the web app icons didn't change in Chromium. I'm wondering if it's Chromium's fault.

Pedro Bessa (deltrem1984) said : #3

When I remove "kdocker " from "Exec=" in a shortcut and use the shortcut, when the page loads, the icon changes in Chromium's top left. So, the icon must change in KDocker too.

Pedro Bessa (deltrem1984) said : #4

I updated my question and wish I could remove comments 1, 2 and 3.

John Schember (user-none) said : #5

What version of KDocker are you using?

Pedro Bessa (deltrem1984) said : #6

4.3-0ubuntu1

John Schember (user-none) said : #7

This bug should have been fixed in the 4.4 release. The latest release (as of Jan 6, 2011) is 4.5.

Pedro Bessa (deltrem1984) said : #8

I updated kdocker to 4.5~lucid0, but that part still doesn't work.

John Schember (user-none) said : #9

"as the page loads, the icons change in top-left." Is the icon on a tab by chance?

In Preferences go to the "Personal Stuff" tab. Do you have "Use system title bar and borders" selected? If not enable it and let me know if the icon in the title bar's corner changes. I'm not seeing it change and that is the icon KDocker retrieves from the application.

Pedro Bessa (deltrem1984) said : #10

I set the icon to /path/chrome-https___imo.im_new_.png, then closed, then reopened the app. Please, remember the icon that I want for the app.

Pedro Bessa (deltrem1984) said : #11

kdocker -i /path/image.png therest!!!

Pedro Bessa (deltrem1984) said : #12

I edited the app shortcut line:

Exec=/usr/bin/chromium-browser --app="https://imo.im/new/"

to:

Exec=kdocker -i "/home/deltrem/.local/share/icons/hicolor/16x16/apps/imo.png" /usr/bin/chromium-browser --app="https://imo.im/new/"

Now, it runs imo, autodocks it and sets its icon to imo.png.