How to increase the wait time for opening a window

Asked by Christopher Martin on 2010-05-30

When a window times more than 5 seconds to launch, kdocker throws a fit and refuses to dock, giving only the message "Could not find a matching window for xxxxxx in the specified time: 5 seconds."

This is rather funny behavior since many applications take longer than 5 seconds to launch, and rather funny message since I did not "specify" 5 seconds. Is there a way to lengthen this timer to something more reasonable?

Question information

Language:
English Edit question
Status:
Solved
For:
Inactive kdocker (moved to https://github.com/user-none/KDocker) Edit question
Assignee:
No assignee Edit question
Solved by:
John Schember
Solved:
2010-05-31
Last query:
2010-05-31
Last reply:
2010-05-30
Best John Schember (user-none) said : #1

5 seconds is an arbitrary default. Use the -d option to specify a longer time.

Christopher Martin (ch-martin) said : #2

Thanks.

The man page need updating, then... The entry for -d says "Disable session management. KDocker will not attempt to redock this application when you relogin."

Christopher Martin (ch-martin) said : #3

Thanks John Schember, that solved my question.

John Schember (user-none) said : #4

>The man page need updating, then... The entry for -d says "Disable session management. KDocker will not attempt to redock this application when you relogin."

I'm assuming you're using Ubuntu? They added their own man page and it is not part of the KDocker project. As you can see the man page they've added is very incorrect.